Rebuild fails with theme/version warnings after adding chat plugin (still fails after removing)

Well, fresh off of solving one issue, I am now running into another. I had things working and wanted to try to install the chat plugin. I added it to app.yml and did a rebuild and started getting theme-related errors:

Failed to update 'Alternative Logos': about.json contains invalid values: Maximum discourse version is invalid
rake aborted!
RemoteTheme::ImportError: about.json contains invalid values: Maximum discourse version is invalid

And at the end of the build:

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake themes:update assets:precompile' failed with return #<Process::Status: pid 3923 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"assets_precompile", "cmd"=>["su discourse -c 'bundle exec rake themes:update assets:precompile'"]}

Now I realize the chat plugin is in pre-alpha. I am posting this here, outside of the Chat category, because I don’t think it is necessarily a chat-related issue. It also seems almost exactly like this already-reported and resolved issue which doesn’t seem plugin-related:

I’d reply there, but it’s closed. My issue is basically the same, at least as far as the errors. Still getting errors after removing the chat plugin from app.yml, too.

Now, I haven’t followed the resolution steps in that topic I linked to above yet. I’m posting this first in case it can help to track down the reasons this issue occurs (and potentially make it occur less/not at all). I am not in a rush to fix this, so if this is of interest to anyone at CDCK, let me know. I will try to tackle the fixes as outlined in the above thread later tonight or tomorrow morning.

OK, this is now resolved. I rebuilt one more time, got similar errors, but the app did come up and I was able to access the standard admin area, remove problematic Theme Components (the alt logo one already mentioned in other threads was also implicated in my case), and then finally a rebuild completed without errors. I even got the Chat plugin installed after that, so indeed the issue seems unrelated to it.

Here’s my best guess as to what occurred:

  • I setup Discourse in Digital Ocean using their standard Discourse image
  • I am migrating from another host, so I did a backup of the existing Discourse site
  • That backup had old/non-updated themes and theme components in it
  • When I restored the backup to the new server, the restore worked
  • When I attempted to install the chat plugin, this is when the issue started to occur, upon manual rebuild
  • I removed the plugin (commented out in app.yml) and tried to rebuild, but continued getting errors
  • I gained access, whether by chance, or simply from greater patience (see below) to the web admin
  • After removing non-updated themes and theme components, and updating the rest, it works

So what I appear to have learned from this is that Theme Components with bugs, even (it seems) incorrect max version values, can break Discourse, at least a bit. I wish that such an issue would not cause so seemingly significant of a failure. But I suspect that I may also have made some assumptions in this process so that it seemed like the app just wouldn’t come back up without a rebuild, when it may actually have just been taking a while to start or something. That’s the only explanation I have for why it seemed to come back up upon revisiting it today, after a rebuild that showed similar/same errors. I may just not have been patient enough and Discourse may not have been so truly broken as it seemed…

Still trying to get the hang of how Discourse is hosted and managed. Apologies for my occasional flailing and confusion. :yum:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.