Red triangle when offline has no message when clicked

Try this experiment when composing a new post.

Fill out most of the post, then go offline.

A red triangle appears in the lower right.

Tap the red triangle.

You’ll get one big blank page.

Certainly whatever it was trying to retrieve needed to be retrieved when online!

:wave: Dan

I’ve tried clicking on the triangle but I don’t think that’s a button. I could only get a black page if I accidentally clicked on the :desktop_computer: button which shows a preview of your draft. But if you’re writing something it shouldn’t be a completely blank page :thinking:

On desktop its a bit more obvious


I get the exact same problem on a self hosted instance, I tried updating the host OS and updated discourse to 3.3.0 beta 1 same problem.

The issue seems to be an authentication (http 403) problem loading drafts.json

Found the problem. I have Cloudflare in front of my site and for whatever reason it has started to present a javascript enabled Challenge page when requesting drafts.json

[Specifically I think this was caused by the Cloudflare WAF feature using the Cloudflare OWASP Core Ruleset]

1 Like

Well, I saw it right here on Meta, so Meta must be using Cloudflare too.

Also, most users would like to know what the red triangle means so that’s why they’ll tap it.

I mean what if there’s a warning light on your car dashboard and there’s no way to tell what it’s all about?

I cannot reproduce this, Chrome Windows 11 & Chrome Android 13. Both versions of the triangle cannot be clicked. However, on mobile if you push the :desktop_computer: icon, it opens a blank preview.