Redirection issue after changing the nameserver


(Jk Baseer) #1

Hello Guys!
I am starting this thread with a bit doubtful mind whether this is supposed to be asked here or not. I would immediately close if this is totally not related here. or
[Please close this topic if this is not relevant to Discourse]

I have been trying to forward users whoever visit example.com to forum.example.com. I have done this successfully via Redirect single/multiple domain(s) to your Discourse instance (first message) no problem at all by adding in the app.yml . It worked for few days. Recently we changed the nameserver from namecheap to godaddy and also update the Digitalocean nameserver in godaddy already. It’s been almost 10days but still the main domain redirection is not working. However, the subdomain is working without any hassle.

With a guess based approach, I did check the app.yml in var and it’s the same. And made a launcher rebuild app in case if that could have helped.

Not working. As there is nothing much changes i did on DO and also the nameserver in godaddy has been already amended. What could have been the issue?


(Jk Baseer) #2

Hello Anybody, Just double checking if this is not something to do with discourse ?


(Stephen) #3

The reason you’ve not received a response is because it’s almost certainly down to the DNS configuration at your new host. Your @ record (for the root) is likely missing or incorrect.

As you’ve not specified your domain we can’t look at this for you, but either way it’s something you’ll very likely be fixing by correcting your DNS entries.


(Jk Baseer) #4

Thanks Stephen. The reason why i want to share it might not be to do with DNS is because Redirect single/multiple domain(s) to your Discourse instance according to this link, the redirection setup was done on discourse app.yml and not the DNS setup.

To be exact am sharing here the code in app.yml for the redirection

 - file:
        path: /etc/nginx/conf.d/discourse_redirect_1.conf
        contents: |
          server {
            listen 80;
            server_name example.org;
            return 301 $scheme://forum.example.org$request_uri;
          }

In this case, is it still nothing to do with app.yml?


(Stephen) #5

If it worked, then stopped working and all you’ve changed in the interim is DNS, then it’s a DNS issue.

You said to be exact, but are you? Did you specify example.org in your real app.yml? If so this would have never worked.


(Jk Baseer) #6

could it be something like cache clearance in discourse? Just asking.

Ah the example.org i changed it in this thread from the real name for making it easier to understand. There is no change done in the app.yml.


(Stephen) #7

Caching of what? You probably need to elaborate on what you think discourse is caching.


(Jk Baseer) #8

Sure. Caching of the App.yml settings when the app is running every time.
For example: When the user loads website repeatedly, the web contents are sometimes cached. Similarly can the DNS settings could be cached in discourse

I kept this message in draft. But apologize there isn’t any such things :smiley:

The mistake I done is.
The A record setup was *.example.org. However it should be @.example.org.

Thank you for taking time to double confirm!


(Dave) #9

DNS is used by others to find your site. As you’ve found Discourse wouldn’t be caching it. DNS is like mail, routing or firewall config where many devs and/or admins aren’t fully aware of how exactly it works. They can be as complex as developing an app but in different ways.

The primer from Dyn is a good place to start.