Rename feature voting to something more encompassing

In my community I am seeing this plugin as useful for voting on a range of things.

  • candidates for leadership positions
  • strategic priorities for the community
  • projects to support/fund
  • conference/event session proposal voting (thanks @downey)

In each of these cases we’d set up a special category, open it up for voting and discussion during a limited voting period, and then close it again when we’re done.

So… if such wider usage of this plugin is generally likely to happen, perhaps it should be called “topic voting” instead of “feature voting”.

I also wonder if it wouldn’t make sense to provide category admin settings for the number of votes and super votes available per user in the category.


Naming is VERY important. My call here is to just rename it to “discourse voting”, @codinghorror is that OK with you?

“Topic voting” has a terrible ring to it, too many words :slight_smile:


I like Discourse Voting, goes very nicely with Discourse Solved.


Off topic, but I am pretty sure you would need this complete first prior to allowing for this use case.

1 Like

This is now complete, the plugin is called “Discourse Voting”, repo was moved all localization was changed to reflect and all source code and references were changed to reflect.