Retort - a reaction-style plugin for Discourse


(Lars) #105

Works perfectly. Thanks for your swift action :smiley:


(EW 👌) #106

I did installed this Retort plugin recently and its work fine thank you for the nice plugin :sparkles:

I’m facing two bugs:

  1. When I did installed Retort plugin I’d started to get an error with Rating plugin (I did reported at Rating Plugin Cat.)
  2. I’d just tried Retort functionality with Firefox last version (Win 10), I’d noticed that when I click on the smiley icon to react, I’m getting my screen darkened but without the icons to react from (not even there white background). If I click again anywhere, the screen get back normal. No error log on this. But when I’m doing the same with Chrome at the same PC, there is no problems. Everything working as expected.

Edit:
I’m getting the same bug at Chrome too. For testing, I’m using my site opened on two tabs with different user names at the same Chrome -last version. (Normally you can’t do it because of cookies but I’m having one tab opened this domain https://community… and the other https://www.community…). One of them is working fine, the other is acting as explained above with Firefox!.

Edit 2:
It’s interesting. I did tried the same scenario of two tabs at Firefox and I discovered something strange. If your site domain start with :// then you have a problem. If your site domain starting with ://www. then the plugin is working fine!.

So it’s seems that this may be the issue of whom having problems depends on there site domain setup!
I hope this could help you to debug and fix the real reason.


(James Kiesel) #107

Unfortunately I really can’t imagine anything in Retort being affected by something like this. Are you able to see this erratic behaviour with the regular emoji picker in Discourse? Are you able to repro on discourse-babble.com?


(EW 👌) #108

No I’m not. I just tried it in both tabs. It’s working fine.

I just tried at discourse-babble.com from my Chrome & Firefox and it was working just fine too!

The reason maybe something else but this is what I was able observe from here. It was strange to have this exact behavior of Chrome and Firefox effected if I had the www sub domain or not! And its effecting only the behavior of Retort for that I thought you are the only one who could help!

Edit:
You are right. It wasn’t related to the sub domain type. It was happening randomly. When I logout and login with different user, it was working sometimes, other times not! I lost what could be the reason but its still happening randomly!


(James Kiesel) #111

They don’t; retorts are stored in a completely separate fashion to likes in
the system. Tying that sort of stuff into this plugin will make it much
more prone to breakage, so I’d be hesitant to introduce this kind of thing.


(James North) #112

I must say I have the same issue with current safari on OS Sierra.

More often than not, the grey overlay occurs and shows no emojis.

It seems to work more often on mobile versions of Safari at this stage.

I know others on the forum have the issue too, so they just don’t use it.

I might try to do some further testing myself.


(Kovah) #113

I’m very sad to say this but the plugin does not work with version 1.8.0. The plugin settings appear in the backed but the button is not showing on posts. Seems that 1.8 did some breaking changes as other plugins stopped working too.

Current version: 1.8.0.beta6


(James Kiesel) #114

http://discourse-babble.com is running the latest version of retort and Discourse, and seems to work alright. Any other circumstances you can identify to recreate this?


(Kovah) #115

Thats weird. I double checked, everything seems to be correct. The plugin is active, changing settings does not affect anything.
The only errors logged in the console are caused by application.js and ember_jquery.js:

Here’s my plugin list, maybe you know a plugin that caused problems with Retort in the past?

If there’s any other way to debug this behaviour I’m ready to do so, but I don’t have a clue about both Ruby and Ember.


(RJ) #116

Hello, I’ve downloaded this plugin, and also tested the plugins on your test site. Unfortunately it’s not working for me either, as the guy above said there’s no emoticon to select in the post menu. I looked in the log and didn’t see any errors.


(James Kiesel) #117

Thanks for the report; there was a conflict with the latest discourse version. Updating to the latest should fix it.


(Kovah) #118

After running the updates it is now working fine.
Thanks for your aweome work!


#119

We are having a bit of an issue on our forum. It seems for some users (myself included), when they click on an existing reaction or try to add a reaction that has already been used, the count for that reaction doesn’t automatically update. If you refresh the page, the count updates, but if you don’t know to do that it looks like it’s just not working. Until another user pointed out the refresh, I assumed it wasn’t working for me so I stopped using it. I’m using Chrome, another user has reported the same behavior on Firefox.

Also, random dark screens with no emoji picker here as well for several users across browsers and platforms. I’ve found a log out and back in to the forum usually fixes it.


(DiscourseMetrics.com) #120

Seeing the same bug here :slight_smile:


(James Kiesel) #121

Thanks for the report. This should now be fixed in latest.


#122

Hi there;
Hey there, I’ve installed the plugin, however, the button/emoji are not appearing below the topics. Is there any additional step i need to take of is it not working with the latest Discourse version?

The plugin is activated!


(James Kiesel) #123

discourse-babble.com is running the latest version, so I don’t believe it is broken. Do you have errors in the console? What do your plugin settings look like?


#124

Hi there, thanks for responding.
I installed it; it shows as activate on the admin panel. I get no error, nothing. The button that is supposed to be there for reactions is just not there!


(Yaw Anokwa) #125

I am also having this problem. I am running v1.9.0.beta4 +174 and here are my settings…


(Marc Billow) #126

On the latest version of Discourse, I am running into this error. Assuming that the plugin just needs to be updated to support the new emoji picker.

Error: Could not find module discourse/lib/emoji/toolbar imported from discourse/plugins/retort/discourse/initializers/retort-init