Right to left languages when mixed with english (left to right) will not show properly

If I enable mixed languages in discourse settings, writing English and Arabic in one line will not display it properly. For example:

(On the right side is the edit part, and on the left side is what is shown to the public)

  • What should happen

Continue as well to the left<—English word<–continue to the left–arabic–

  • What is actually happening

^ Then it will go backward<—English word<–continue–arabic–

OK so how do we solve this? disable this mixed option from settings = Ta Dah! it will solve the issue, but another issue is going to arise:


This actually it should be:

  "experimental": true,
  "ip6tables": true

Yes if you copy/paste the text it will show it properly, but by the look of it from users outside it doesnt look correct.

Discourse version: Discourse 3.2.0.beta2-dev