Script to enable Matomo analytics on Discourse

Matomo is an open source analytics platform. Users can choose between self-hosting or paying for professional hosting in the cloud.

Note: Matomo was formerly named Piwik. See Piwik is now Matomo - Announcement - Analytics Platform - Matomo for details about the name change.

To enable Matomo analytics on your Discourse forum, all you have to do is install the official theme component.

Valid for Matomo API v1.5 and newer

  1. Follow the theme installation guide to import from the following URL:

    https://github.com/discourse/discourse-matomo-analytics.git
    

    And you will see

    05%20AM

  2. Enter the Host URL and Website ID

  3. Add the theme component “Matomo Analytics” to your active theme(s).

That’s it!

Thanks to @mattab & @brahn for updates
Updated by @tagtomat after @Simon_Cossar helped setting it up on our forum

31 Likes

Thanks for this howto, works fine for me. :thumbsup:

In order to comply with the European laws, users must have the possibility to reject piwik’s cookie. Piwik offers a really simple solution for this, by including an IFrame.

Unfortunately, Discourse doesn’t allow iframe tags in posts… :grimacing:
Does anyone see a way to include this piwik iframe in Discourse TOS ?
Thanks.

1 Like

:wave: I just created a new “Matomo Analytics” theme component, and updated the instructions on how to set it up.

Could you give it a try? Please also remember to remove the original custom scripts.

8 Likes

Looks good on first sight. No error in javascript console. Requests to piwik.php being in the webserver log again.

Statistics in Matomo are available as well.

5 Likes

Is this iframe thing still a concern?

1 Like

Hey @xrav3nz :clap: your component works great - thanks!

Yes it is. Opt-out should be possible, and Matomo provides this via including an iFrame: see Matomo documentation

3 Likes

This doesn’t appear to be working for me at the moment? I can add the component, and add the correct URL and siteid, but it doesn’t render anything:

I added the comments around the code to find it quicker in the page:

image

1 Like

We are on beta 6+git1 on our instance

Inline JavaScripts in themes and components are automatically extracted to an external “theme JavaScript” file.

Could you try checking the one immediately after your comments?

9954b74cfdb3c6f0230e7e9f4c6a3db0764c1373

7 Likes

This is at the main page on https://discuss.pixls.us:

Edit
Hold on, I’ve got a new hash on the file on recent refresh, it looks like the code is there. Thank you @xrav3nz!

Looks like it’s working now - not sure what I was doing wrong yesterday - user error.

5 Likes

So I have the JS loaded into the theme customizations, and the external “theme JavaScript file”* is linked in my test browser, just under where I inserted it like in the screenshot in a few posts earlier … BUT the requests aren’t coming through to the Matomo tracking web server.

(Tracking works fine for other non-Discourse sites, FWIW.)

Has anyone else seen that happen?


* e.g. https://discourse-cdn.example.com/standard11/theme-javascripts/{numeric_string}.js?__ws=my-discourse-forum.example.org

Thanks for the component!

I’m confused why the tracking code is sending a custom variable called Anonymous. Isn’t that custom for your particular Matomo setup? It doesn’t seem like it should be there for everyone.

_paq.push(['setCustomVariable', 1, 'Anonymous', !currentUser, 'visit']);

I added a few lines so that it would track visitors between discourse on a subdomain and a main site. Happy to send a pull request if you want it.

You have to whitelist your Matomo-URL inside the Content-Security-Policy-Header. Search for the admin setting content_security_policy_script_src and add your domain (with https:://) there

4 Likes

I’m having trouble making this work on my installation. I’ve installed the component, and added it to my theme, but Matomo is saying there’s no data for the site. I’d think I have the settings correct:
image
image
But I’m seeing this error in my browser console:
image
…and when I look at the site in Matomo, I get this:
image
What am I missing?

Edit: Further investigation reveals that the error in the Javascript console only appears in Firefox, not in Chrome (with the latest versions of each on a Mac). And I am now seeing some results in Matomo, though Firefox is conspicuously absent–all but one of the visitors are using Chrome; the one exception is using Safari.

Any thoughts on this? This post:


suggests that it could be Firefox’s “do not track” settings, but even when I disable them for my site, I’m getting the same error in the web console with Firefox. And Firefox doesn’t seem to be viewing this as a tracker in any event:
image

Try to remove the last / of “Sign in - Matomo” --> “https://www.familybrown.org/analytics

1 Like

Thanks. Unfortunately, I’m still getting the same error:
image

Could you give me the URL of your forum?

Is this working or not ??