"Send me an email for every new post" - can't deselect once selected


(T) #1

On the preferences page I can’t deselect the option “Send me an email for every new post (unless I mute the topic or category)”.

I am using an Administrator account and the setting: “default email mailing list mode” is unticked.

The version of Discourse I am running is Version v1.6.0.beta1 +277. I can’t replicate this on another instance of Discourse I have running which is Version v1.6.0.beta1 +92.

Please advise, thanks.


(Dean Taylor) #2

Works for me on v1.6.0.beta1 +288 (EDIT: in Google Chrome)

Perhaps:

  1. Try a different browser
  2. Disable browser plugins
  3. ensure you are up to date with latest
  4. disable any Discourse plugins you have added.

(T) #3

Thank you Dean!

I can deselect this preference using Chrome on OSX El Capitan but not on safari 9.1 on OSX El Capitan or IE11 on Windows 7.


(Dean Taylor) #4

I can confirm this is a bug.

I’ve tested on Windows 10 IE 11 - I am unable to deselect the "Send me an email for every new post (unless I mute the topic or category) ".

Unexpected prompt “Are you sure you want to be emailed for every new post?” is displayed with Yes/No buttons when deselecting.

Although this works fine on Google Chrome.


EDIT:


(Jeff Atwood) #5

Almost certainly a bug, @sam with the dialog alert?


(Marcus Baw) #6

I’m also having a lot of users reporting that the ‘Send me an email for every new post…’ option is greyed-out meaning they can’t unselect it. Weirdly though, if I Impersonate them, it’s usually fine and I can unselect it for them. I was wondering if this apparent bug might be related to the one reported here.


(Arpit Jalan) #7

Fixed via:

Thanks for brining this in our notice @T_Disco :thumbsup:


(Arpit Jalan) #8