Setup Multisite Configuration with Let's Encrypt and no Reverse Proxy

Single Website-NormaI Setup works perfect. No problem.
But I tried many combinations for multisite. Single app.yml configuration or seperated by web_only.yml, data.yml vs…I tried other tips on Multisite configuration with Docker or Move from standalone container to separate web and data containers.

As for the migration part all combinations always failed… >>>> bundle exec rake multisite:migrate

********************** last part of the process**************************
2023-02-11 17:50:43.853 UTC [61] LOG:  shutting down
162:M 11 Feb 2023 17:50:43.866 # User requested shutdown...
162:M 11 Feb 2023 17:50:43.866 * Saving the final RDB snapshot before exiting.
162:M 11 Feb 2023 17:50:43.881 * DB saved on disk
162:M 11 Feb 2023 17:50:43.882 # Redis is now ready to exit, bye bye...
2023-02-11 17:50:44.007 UTC [57] LOG:  database system is shut down

Pups::ExecError: cd /var/www/discourse && sudo -E -u discourse bundle exec rake multisite:migrate failed with return #<Process::Status: pid 582 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.1.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params "cd /var/www/discourse && sudo -E -u discourse bundle exec rake multisite:migrate"
bootstrap failed with exit code 1
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

I checked what was created and what was not created until the failure.
Subdomains databases are created but migration failed. Subdomains nginx conf or multisite.yml couldn’t be created when I checked overlay2 folders or anywhere.

./laucher bootstrap,destroy,start,stop,rebuild or fresh setup many times …Tried all commands but nothing happened… :slight_smile:

Is this tutorial still valid for v3.1.0.beta 2 or what could I be missing?
Any idea, please ?

1 Like