unable to retrieve Discourse statistics API

Hi everyone,

We’ve had a Discourse shield on our repository for a while now, and it recently stopped working.

If you go to and select any Discourse shield, you can enter your discourse domain address and it will show you the shield with the correct statistics. You can try this with

However, when we enter our discourse host address (, for any statistics and for both http/https, it always returns “invalid”.

Discussion Forum

When a host is not found, would return “inaccessible”. Thus we assume “invalid” means it’s accessible but there are access rights issues or invalid responses.

Is it possible that a recent update/upgrade broke something on Discourse statistics API that uses?

Thank you so much!

It’s working for me in my site, maybe you’re not setting correctly the protocol? Or the Grakn Discourse has any kind on modification that breaks that endpoint.



You might want to ask about that problem. It works with all other sites I tested, so this isn’t our bug.

1 Like

@marianord that’s exactly my question: where are the “protocols” you’re mentioning? How can they be configured? I’ve not changed any settings.

@gerhard given that is working for other Discourse sites, it does not seem likely to be an issue on their side. Unless they’re re not reading the output from our site statistics properly - but how can we find out about this? What is the endpoint from Discourse that is used to query the statistics? Perhaps we should start there?

I’m mentioning http vs https.

1 Like

This happened because our Discourse installation blocked’s user agent ( This setting is named whitelisted crawler user agents and can be edited at

1 Like

Interesting! Thank you @max_grakn! We did add Googlebot to the whitelist recently, I think that may be the cause.

@codinghorror are we meant to use Blacklist and Whitelist at the same time? As in, if you add things to whitelist, does that mean everything else is blacklisted (which therefore make the blacklist redundant)?

No, the crawler whitelist is very dangerous, and should only be used carefully per the help text.

User agents of web crawlers that should be allowed to access the site. WARNING! SETTING THIS WILL DISALLOW ALL CRAWLERS NOT LISTED HERE!

1 Like

Hi, I have the same problem when a test I received invalid data… do you have idea ?

It’s OK now, it’s necessary to activated anonymous statistic in :

Admin → setting → other → share anonymized statistics = Enabled

and now it’s ok for

1 Like