Sidekiq Gem::ConflictError


(OG) #1

Hi, I’ve stumbled upon this issue, hard to tell what I’ve done wrong and changed in the process. My sidekiq was working well but suddenly I can’t start it…

overgrow@axii:~/discourse$ sidekiq
/home/overgrow/.rbenv/versions/2.3.0/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:2288:in `raise_if_conflicts’: Unable to activate actionpack-5.0.0, because rack-1.6.4 conflicts with rack (~> 2.0) (Gem::ConflictError)
overgrow@axii:~/discourse$ gem list --local | grep rack
rack (2.0.1, 1.6.4)
overgrow@axii:~/discourse$ gem list --local | grep actionp
actionpack (5.0.0, 4.2.7)

I’ve already tried running bundle install


(OG) #2

Anyone? thanks in advance…


(OG) #3

Finally… Solved… I have downgraded sidekiq to 4.1.2

gem uninstall sidekiq

gem install sidekiq --version '<=4.1.2'

/home/carlos/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:35:in block in setup': You have already activated activesupport 5.0.0, but your Gemfile requires activesupport 4.2.7. Prependingbundle exec` to your command may solve this. (Gem::LoadError)

So bundle exec sidekiq works perfectly…


(Robin Ward) #4

You shouldn’t have to install sidekiq if you did bundle install. You should run it use bundle exec sidekiq and it should use the one from the project.


(OG) #5

Ok, I got it… Thank you!


(Robin Ward) #6