SimpleSAML login

ive got two problems…
previous lad made SAML possible now i reinstalled discourse that is in docker and i got saml plugin running and im welcomed to login screen but after login on saml im redirected to blank

“correct domain”/auth/saml/callback and it seems i even cant find where are logs

1 Like

Your can log in to your forum at /u/admin-login.

Your should then be able to find the logs at the admin page.

1 Like

i found logs in /logs URL :slight_smile: but /u/user got me there. i dont know what is missing in settings that LDAP user cannot neither register nor login… i tried both but i get empty page…here is log …in settings i didnt provide fields that should match it says itll will be automatic would that be cousing a problem? password and user are correct i tried directly loging in LDAP… below are logs traces

SAML was previously working when site wasnt build in docker so i guess …i need to set up additional settings in SAML but i cant find documentation on how to proceed

i didnt proprerly configure SAML plugin to use PUT method as i saw now in their github… now i dont send certificate for discourse from our SAML site. is that a must? previously it was working without certificate. is discord SAML proper plugin to login users from remote simpleSAMLphp?

im still having issues logging users with SAML in discourse this time i received following error on screen.


The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We’ll take a look at it.

Message (2 copies reported)

OpenSSL::X509::CertificateError (PEM_read_bio_X509)
lib/middleware/omniauth_bypass_middleware.rb:53:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:369:in `call'
config/initializers/100-quiet_logger.rb:20:in `call'
config/initializers/100-silence_logger.rb:29:in `call'
lib/middleware/enforce_hostname.rb:24:in `call'
lib/middleware/request_tracker.rb:228:in `call'


ruby-saml (1.13.0) lib/onelogin/ruby-saml/settings.rb:186:in `initialize'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/settings.rb:186:in `new'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/settings.rb:186:in `get_idp_cert'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/response.rb:862:in `validate_signature'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/response.rb:403:in `block in validate'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/response.rb:403:in `all?'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/response.rb:403:in `validate'
ruby-saml (1.13.0) lib/onelogin/ruby-saml/response.rb:79:in `is_valid?'
omniauth-saml (1.9.0) lib/omniauth/strategies/saml.rb:132:in `handle_response'
omniauth-saml (1.9.0) lib/omniauth/strategies/saml.rb:49:in `block in callback_phase'


i specificaly added certificat to saml response and put public part into SAML plugin. the public part i created with openssl and now i get error certificate error… i think main problem here is dealing with certificates… but im unsure how to proceed …any help would be very welcome.

got it working :slight_smile: it was certificate problem …

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.