Site automatically exits read-only mode when enabled by 'discourse enable_readonly'

Hi Lilly,

Thanks for your response. This is a fresh default install and I’ve not installed any plugins or created any jobs. Which logs am I best to look at? Sorry I’m a bit of a noob.

I’ve tried tail -f on:

/var/discourse/shared/standalone/log/rails/unicorn.stdout.log
/var/discourse/shared/standalone/log/rails/unicorn.stderr.log
/var/discourse/shared/standalone/log/rails/production_errors.log
/var/discourse/shared/standalone/log/rails/production.log
/var/discourse/shared/standalone/log/rails/sidekiq.log
/var/discourse/shared/standalone/log/var-log/redis/current

I waited for the event to occur while following the logs but I didn’t see anything that stood out.

It’s odd to me that it works perfectly when activated via the WebUI but not via cli.