Site broken after update

I just updated to Discourse 2.7.0.beta6 (from beta5, I believe) using the web updater and now my site isn’t working correctly.

The logo and menu bar at the top are missing and even though categories and posts are visible the posts don’t open correctly but are empty. Only the title (and categories underneath) and Reply are visible.

The 404 page displays the logo and Sign up / Login but the login box doesn’t show up when I click on it, only black.

Curiously in Firefox “show HTML” doens’t work but keep trying to load. Works in Chrome though.

I tried rebuilding the site again using the CLI and it seemed successful but didn’t repair anything. I also tried clearing the redis cache and rebuilding it again…

Also disabled some plugins and rebuilt, didn’t help

Also tried restoring a backup as I would hope it would revert the whole system to the functioning older version but that didn’t help either.

Running out of ideas and energy… Any help, please?

Have you tried Safe Mode?

If that works, then it means the issue is likely caused by a theme or plugin.

A few theme components have been broken by recent core updates, so you may want to try updating and/or disabling them one by one until things work without safe mode.

1 Like

Wonderful, thank you, this seems to help.

Ok, the culprit was this old plugin I didn’t even remember I had installed:-

Too bad I didn’t find the safe mode earlier when googling for howto repair a Discourse site and went through so much experimentation. But I learned a lot about Discourse from this.

2 Likes