Site installed but NO admin email activation

Hey guys,

The title says it all. I installed discourse maybe 10 times on Ubuntu 20.04, CentOS 7 and even on a pre installed Docker on Debian 10 changing every time a bit in the discourse setup part, thinking what went wrong when for the first time admin login page shows up and yet clicking on activate my account BUT not receiving any emails :frowning:

I use Sparkpost for smtp besides using gmail as well worked for me but nothing is changing…!

Can someone explain in plain language with no confusion what should be done to get the forum up and running??

PS. I even used my default domain name not the subdomain to get working and still no luck!


Have you checked sparkpost logs for a reject reason?

No as a matter of fact but will take a look at it now!

Edit from here:

  1. There is no logs to track in sparkpost.

  2. My domain wasn’t verified but when I try to do so I got one:

Unable to verify cname record of

DNS CNAME query error: No CNAME records retrieved

and the second time I got this:

HTTP request to failed. Please verify that your redirect is functioning.

I have no clew why this happening :frowning: :frowning:

Please see Troubleshoot email on a new Discourse install

Now I get 404 Not Found on openresty

I managed the installation 10 times but I’ve done it twice in an hour and got same 404 sign :frowning:

Then I doubt sparkpost will deliver mail.

You have somehow broken your DNS. I cannot imagine how or why. You shouldn’t need to change the A record for your site. If you use some dns service like cpanel it can be hard to create the TXT records required for mail delivery.

If you install from the start many times let’s encrypt will refuse to issue you a new certificate so you’ll need to wait a week or use a different subdomain.

Now I got my mail or domain verified but I guess you’re right my dns is broken somewhere and I have work on that over the weekend …!

Will report back if I got it worked out … who knows maybe others would learn from this and don’t fall in the same trap like I did :smiley: