Site refuses to connect after installation

I’m totally new to this so I’m sorry if I won’t understand some of the things you guys will tell me.

So I installed the newest version of Discourse on DigitalOcean (Ubuntu 18.04). Everything went smoothly after the 4th attempt and when I tried to go to the website - I’d get this:

This site can’t be reached

****  refused to connect.


* Checking the connection
* Checking the proxy and the firewall


While I already searched through the forum and tried to find a possible solution on my own, I’d go and try to check the logs with./launcher logs app where I’d get bash: ./launcher: no such file or directory and it also looks like app.yml is missing?

I read somewhere else in here that there’s a weekly limit to how many times one can try to install Discourse from what I understood so is there a possibility that I’ve might’ve reached the limit?


did you follow these install instructions?

1 Like

No. Kinda found it hard to follow. I followed this tutorial instead

1 Like

did you install cloudflare ?

1 Like

Please have another look. To get help here, you really need to follow these instructions. If you don’t follow those instructions, we can’t guess what you might be doing wrong because we can’t tell what you’re doing or what you’re trying to do.

Since you follow different instructions you should try to get help from the guy who made the video, or the good folks at Digital Ocean who made the 1-click installer. (Last I knew, the person that the person responsible for maintaining those instructions no longer worked there, but that could have changed several times since then.)


I redid everything this time following the instructions and while Discourse was installing, I noticed that there are a few [DEPRICATED] errors going around. Still won’t let load the website. Will be definitely going to ask about it over at Digital Ocean. Thanks anyways

1 Like

In that case, you probably have a problem with the DNS for your site not pointing to your droplet, though if you ran ./discourse-setup it should have warned you about that.

Does ssh your-host-name connect you to your dropetl?

Good eye! But they are just warnings and aren’t the problem.


Ok so I went and got busy with other stuff because I got too frustrated with the site. Checked my email and found that DigitalOcean sent me a “welcome” message even though it’s been a week since I was registered on the site and already got one? Went to my discourse website to see if it maybe is working and it does.
It was an error on DO’s side. Thanks again to everyone who tried to help :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.