Fresh Discourse installation ERR_CONNECTION_TIMED_OUT

Hi, this is my first time setting up a site with a VPS. I’m using Digital Ocean and I followed this guide (set-up-discourse-digital-ocean) step by step with a fresh install. This is I think my 4th time restarting and I can’t seem to figure this out. Every time I’ve installed I get some error where I can’t access my site. My domain DNS settings are managed through Digital Ocean. Not sure what information I need to provide for anyone to help me, so if you think you can help just let me know what you need.

My ufw settings are set to default deny incoming, allow outgoing, and allow in ports 80 and 443, but if I check on, it says they are all closed.

Did you run discourse-setup? If you follow the Discourse official Standard Installation you’ll get some clues during installation.

It’s hard to guess without your domain name. My guess is that you are setting dns at digital ocean but those aren’t the name servers for your domain. Can you ssh your.hostname?

If you can ssh to your server then it’s a firewall issue.

it seems that the marketplace discourse installs are faulty.

I would recommend you follow the install manual which @pfaffman also referred to

1 Like

I tried the first couple times with the official install guide from github, but was still getting the same problems and couldn’t load up the site. I’ll try again fresh and see what happens

My bad, forgot to say the my domain is I tried to ssh like you said, but couldn’t connect to port 22. I’m going to reinstall with the official guide again and see where I end up

ssh: connect to host port 22: Network is unreachable

;; ANSWER SECTION:     299     IN      A     299     IN      A     299     IN      A

My guess is that none of those is your droplet?

If you’re using cloudflare, you need to turn off the orange cloud.

If you have rebuilt a bunch of times, there’s a good bet that you’ve hit your let’s encrypt limits and won’t be able to get a certificate issued for a week or so.

Yeah none of those are my droplet, and I did reach my lets encrypt limit, which is why I tried to use cloudflare for ssl. Should I just wait it out and use let’s encrypt?

You first need to create an A record that points to your droplet.

I’d recommend that you just start again and use for your site. It not only solves your immediate problem, but it’s a better idea anyway: Why use www? | www. is not deprecated

I just changed my nameservers in namecheap where I bought the domain to digital oceans so it’s all in the same place. Is this what you mean for my A records? This is what I had before I tried cloudflare and restarted

I just updated my current DNS settings the with the same A records pointing to my new droplet.

If you can now ssh to your droplet with the hostname, you migt be in good shape. See to redirect your apex domain.

I can ssh using my hostname now, here’s what I added in my DNS settings for forcewww

Edit: Finished installing discourse, I still get the same error. Not sure where to go from here, ufw is disabled