Site_setting.tos_url doesn't work

Since there is not a way to make users accept the Terms of Service, I need to redirect them to another location. But that doesn’t work either.

I set site_settings.tos_url = (or any other url- I’ve tried urls both inside and outside the forum). still displays the contents of Clicking “Edit this page” still takes me to

There is a way to add a checkbox to the sign up form, an example is at How to make users to explicitly agree to ToS - #4 by neil, if you are interested in that approach. :slight_smile:

I’m not able to reproduce this bug. When I set the tos_url the /tos redirects to the URL I set (in my case it redirects to Were you perhaps looking at page that hadn’t be refreshed, and still linked to the original topic? :thinking:

1 Like

I should have said there is not a way to make users accept updated Terms of Service, after the signup process.

I refreshed, including Shift-F5 and Ctrl-F5, many times, and it always failed on my home computer. But since you said it worked for you, I tried it just now on my work computer and now it works. I’ll try at home again tonight.

1 Like

I had been changing the text for the setting rather than changing the setting itself:

rather than the setting tos_url.

After all it says “If you have a Terms of Service document hosted elsewhere that you want to use, provide the full URL here.” so that’s my excuse :rofl: