Better handling of accidental addition of default ToS/FAQ/privacy to tos_url/faq_url/privacy_url admin settings

Hello. My Discourse installation was perfect until a pair days ago. I don’t know why, all of a sudden, the error “ERR_TOO_MANY_REDIRECTS” start to appears.

The problem is not because the cookies. Is happening to me at my phone, at my two PC web browsers -after erase the cookies, obviously, and the cache, too-… Is a curious thing too that it only happens at this three pages, the ones related at the title. Isn’t it funny? The rest of the forum is just gorgeous! Thank, by the way, for your great doing with that platform.

The forum is not open yet. We have offered a few invitation links, but the problem started before anyone from outer world came to visit us. I say it just in case this reveals some interest… I think not.

This three pages, are related in any way, are them apart from the others? I can’t understand the situation. Why fails this three but no the rest of the forum?

Can you help me somehow with this matter? I don’t know where to start…

This is the address, if you want to try:

I can reproduce this on my site if I set the faq url or tos url site settings to the default FAQ and TOS urls for my site. Can you check your site settings to see if that is causing the problem for you? These settings should be left empty if you want to use the default URLs for these pages.


Oh, @simon, I love you!! I didn’t related the problem with this settings because the error was recently, and I touched there at the installation beginning, a month or so ago. I suppose I don’t visit this pages (TOS, FAQ…) usually enough!

Thank you very much!

In any case, I think is not very clear the explanation you can found below the little window where you can enter that values. At leas, in spanish. See:


It says like: If you have a document for (privacy p., tos or faq) hosted anywhere, put its URL here… But, isn’t it better to add “but leave it empty if this URL is at your Discourse installation” or something like that? I assume that, writing this few letters more, It would be clearer for other clumsy guys -or girls- like me in the future… :stuck_out_tongue_winking_eye:

Is an idea… Thanks! Gracias!


This might be an error in the translation. In English it says “If you have a Terms of Service document hosted elsewhere that you want to use, provide the full URL here.” That said, maybe Discourse should handle the case when the default URLs get entered into these settings to avoid the ‘too many redirects’ issue.


That’s right! Or maybe, to let it clearer, say: "if the place is at this same installation, let it empty. Otherwise, it can trigger the too many redirects error.

Maybe is too articulated… It can be written simpler and shorter, but the intention, I think it is by this way.

Should we write some tag or maybe write a theme at some category, to make it know to the Discourse Team this should be done, if they think appropriate? Is there a ideas place or something like that?

1 Like

The best approach would probably be to fix the redirect issue so that entering the default URLs won’t break anything. I’ll move this topic to our ux category so that it doesn’t get lost.


I hit this issue today. Maybe just add an admonition to the description to say to add it only if it’s different from the default.

1 Like

Or Discourse could just handle the case. It doesn’t seem unreasonable to add the default URLs to these settings.