Small bugs with tracked topics and split topics

It’s quite details, but:
A) At the bottom of a lot of tracked topics, I see a line saying:

You will see a count of new replies because you [read this topic]

The link “read this topic” doesn’t work. It has the following structure: forum.domain.xxx/t/topic/u/user/preferences/notifications
I don’t know if that’s supposed to achieve something in particular or it’s a bug and the /t/topic part shouldn’t be there. Without it, you end up in the notifications portion of your preferences, and you can adjust the Automatically track topics I enter after x minutes and When I post in a topic, set that topic to. That may be the goal of this link. I’m not sure.

B) If I enter a topic and click to track it manually, it says the same. It would seem more logical to have a line telling me something like “You will see a count of new replies because you selected manually to track it

Just FYI, for topics where I posted or which I created, the line is ending with “because you posted a reply to this topic/created this topic”, which is good. There is NO LINK in this case (there could be, as when “because you read”)

C) SPLIT Topics: I believe I noticed today that when a tracked topic is split, the tracking parameter is set on the split (“forked”) topic, which is good. But it seems Discourse lost the count of the actually read posts. It was only showing me the last answer as unread (and linking me to this one) when there was in fact more than that. This may be a little more complicated, and maybe “normal”. I also only had one occurrence of this, so I’m not 100% sure.

1 Like

I think this is a bug and not a UX issue. The problem is being caused by the lack of a forward slash at the start of the link’s href. For example, for my user, the ‘read this topic’ link is set to u/simon_cossar/preferences/notifications. Editing the href in the console to /u/simon_cossar/preferences/notifications fixes the issue for me.

I just ran into a similar issue with a navigation link that was added through the Nav Links theme component. In that case, the href was set to latest?solved=no. That would take the user to the not-found page if the nav link was clicked from any page other than the site’s homepage. It is my understanding that the link in this form was previously working, but it now needs to be set to /latest?solved=no.

Has something changed with the way Discourse handles these links?

2 Likes

I may be totally wrong on this, but just for my own comprehension, is it the lack of this slash that makes the link point to domain/t/topic/u/... rather than domain/u/... ? (the lack of the slash makes that it’s added to the current url, rather than just the base of the domain ?)

That’s the behaviour I’m seeing. For example, clicking the ‘read this topic’ link for https://meta.discourse.org/t/travis-tests-failing-due-to-eslint/163268 tries to take me to

https://meta.discourse.org/t/travis-tests-failing-due-to-eslint/163268/u/simon_cossar/preferences/notifications

instead of to https://meta.discourse.org/u/simon_cossar/preferences/notifications.

2 Likes