[SOLVED] VM error on Windows 10 during Vagrant setup


(Ryan Harris) #1

I’m running Win10; downloaded the latest VM from the link in the blog but everytime I try the vagrant up command it errors out with the following:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: E_INVALIDARG
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Assertion failed: [!aInterfaceName.isEmpty()] at 'F:\tinderbox\win-5.0\src\VBox\Main\src-server\HostNetworkInterfaceImpl.cpp' (74) in long __cdecl HostNetworkInterface::init(class com::Bstr,class com::Bstr,class com::Guid,enum __MIDL___MIDL_itf_VirtualBox_0000_0000_0036).
VBoxManage.exe: error: Please contact the product vendor!
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage.exe: error: Context: "enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)" at line 71 of file VBoxManageHostonly.cpp

I’ll be the first to admit I’m a noob with Rails and Vagrant but can usually manage setting up a VM box. Here I have no clue how to go about troubleshooting this. Anyone else run into this?
:confounded:


(Ryan Harris) #2

This appears to be an issue with Win10 and VM. To get around this error I downloaded the app mentioned in this thread, followed the instructions, all is good in my tiny world again :slight_smile:

See this thread for possible workaround:

https://www.virtualbox.org/ticket/14040#comment:36

UPDATE:

After running the above fix I encountered another error. This was a timeout during the SSH authorization. Opening the Vagrantfile and adding the line:

config.vm.boot_timeout = 240

Solved that. Hope this helps someone!