Something seems to have gone wrong with my update


(Peter N Lewis) #1

Something seems to have failed with my update to 1.7.x (https://forum.keyboardmaestro.com/).

Nothing is showing up and I’m getting errors like:

I’m wondering if the update failed part way through.

Any suggestions on how to get it going again?


(Jeff Atwood) #2

Have you tried safe mode? Any incompatible plugins can break you.


(Peter N Lewis) #3

No safe-mode does not do any better. It asks me if I want safe mode and I say yes I still get the same result. Nothing shows up at all


(Jeff Atwood) #4

Try rebuilding again from the command line. If you are using any third party plugins, remove them before rebuilding.


(Peter N Lewis) #5

Would that be:

cd /var/discourse
./launcher rebuild app

Will that update any files if they are not up to date?


(Jeff Atwood) #6

Yes, give that a shot, but be sure to remove any third party plugins from the app.yml first.


(Peter N Lewis) #7

I disabled solved and tags

#          - git clone https://github.com/discourse/discourse-tagging.git
#          - git clone https://github.com/discourse/discourse-solved.git

but I get this error when rebuilding:

root@forum:/var/discourse# ./launcher rebuild app
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
app
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2017-01-18T09:41:34.458117 #13]  INFO -- : Loading --stdin
I, [2017-01-18T09:41:34.466939 #13]  INFO -- : > echo cron is now included in base image, remove from templates
I, [2017-01-18T09:41:34.470539 #13]  INFO -- : cron is now included in base image, remove from templates

I, [2017-01-18T09:41:34.470814 #13]  INFO -- : > apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
E: Sub-process /usr/bin/dpkg returned an error code (1)
I, [2017-01-18T09:41:37.110594 #13]  INFO -- : Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 26.1 MB disk space will be freed.
(Reading database ... 34533 files and directories currently installed.)
Removing postgresql-contrib-9.5 (9.5.5-1.pgdg16.04+1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/share/postgresql/9.5/man/man1/postmaster.1.gz because link group postmaster.1.gz is broken
update-alternatives: error: error creating symbolic link '/usr/share/man/man1/postmaster.1.gz.dpkg-tmp': No such file or directory
dpkg: error processing package postgresql-contrib-9.5 (--remove):
 subprocess installed pre-removal script returned error exit status 2
dpkg: postgresql-9.5: dependency problems, but removing anyway as you requested:
 postgresql-contrib-9.5 depends on postgresql-9.5 (= 9.5.5-1.pgdg16.04+1).

Removing postgresql-9.5 (9.5.5-1.pgdg16.04+1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of stop.
Removing postgresql-client-9.5 (9.5.5-1.pgdg16.04+1) ...
Processing triggers for postgresql-common (178.pgdg16.04+1) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
Removing obsolete dictionary files:
Errors were encountered while processing:
 postgresql-contrib-9.5



FAILED
--------------------
Pups::ExecError: apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5 failed with return #<Process::Status: pid 16 exit 100>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params "apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5"
f39c918850fc3105167df6ad93b20c0bdf4678553c6bad4059ebe44016e8d179
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Jeff Atwood) #8

That’s odd. Tagging has been in Discourse as a core feature for a few versions now.

Make sure you add a git pull in there if you were on a very old version:

cd /var/discourse
git pull
./launcher rebuild app

(Peter N Lewis) #9

I was on 1.6.x (the latest before 1.7 I believe).

I’ll try.


(Peter N Lewis) #10

Nope:

root@forum:/var/discourse# git pull
Already up-to-date.

(Peter N Lewis) #11

Should I enter the docker container and then try:

apt-get update

?


(Peter N Lewis) #12

What is supposed to be going on with postgresql?

The error reports

The following packages will be REMOVED:
  postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5

But if I do apt-get update to see what it wants to do, it wants to install postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3

So which version is supposed to be installed? Why would 9.5 be installed already and why would it want to remove it when upgrade wants to install 9.3?


(Jeff Atwood) #13

We updated our docker image to Postgres 9.5 back in May 2016


(Peter N Lewis) #14

OK, my app.xml was still saying postgres 5.3. I changed it to just postgres and the rebuild worked and I am back up and running.

Thanks for your assistance!

Now I should be able to reenable the solved plugin.

I presumably don’t need to reenable the tags plugin as you say.