Sorting by relevance needs additional reload

This sometimes confuses me

When I sorted by “Latest” in my last search, that becomes the default for my next one. Then, searching with AI doesn’t work because I have to choose “Relevance.” But changing it with the dropdown to “Relevance” is not enough. I have to use reload to be able to enable AI search.