SSL problem with SSL proxy

(Torwald) #1

Good day!

I have installed NGINX Reverse Proxy before Discourse, where certificates are managed, so the user connects to Discourse via a secure HTTPS connection.

However, some template files, such as icons, are downloaded over HTTP, which causes Firefox to report an insecure connection. These files are:

<link rel="apple-touch-icon" type="image/png" href="http://
<link rel="search" type="application/opensearchdescription+xml"
<meta name="twitter:image"

and other.

If I enable the “Force HTTPs” mode in the settings, this problem disappears, but there is another - I can neither create categories, nor create new topics, nor even log in - the forum gives the 403rd error.

Version 2.3.0 is currently installed.beta 8 +123.

Thank you in advance

0 Likes

(Jay Pfaffman) #2

There is a site setting called

  force https

Enable it.

0 Likes

(Torwald) #3

If I enable the “Force HTTPs” mode in the settings, this problem disappears, but there is another - I can neither create categories, nor create new topics, nor even log in - the forum gives the 403rd error.

E-Mail confirmation also don’t work when force https enabled.

0 Likes

(Torwald) #4

Here is solution, maybe it will help for someone:

Just add

proxy_set_header X-Forwarded-Proto https;

to NGINX proxy config.

Thnx a lot!

1 Like

(Jeff Atwood) #5

This is covered in many, many topics here…

0 Likes