Starting discourse fails with bootstrap error

Hi Team,

Facing below error when tried running rails server

/var/lib/gems/2.3.0/gems/bootsnap-1.0.0/lib/bootsnap/compile_cache/iseq.rb:73:in `compile_option_crc32=’: wrong argument type Bignum (expected Fixnum) (TypeError)

Running discourse on ubuntu 16.4 and installing in development mode (non docker).


I think I have a related issue. I’m the proud owner of a brand new MacBook Pro and was setting up a new Discourse development environment. I followed @techAPJ’s how to for this to the letter. It all went perfect (well done, sir!) except for the letter avatars. They fail to load.

I did some digging and found this error trace:

RuntimeError - Circular dependency detected while autoloading constant OptimizedImage:
  activesupport (4.2.8) lib/active_support/dependencies.rb:492:in `load_missing_constant'
  bootsnap (1.0.0) lib/bootsnap/load_path_cache/core_ext/active_support.rb:53:in `block in load_missing_constant'
  bootsnap (1.0.0) lib/bootsnap/load_path_cache/core_ext/active_support.rb:6:in `with_bootsnap_fallback'
  bootsnap (1.0.0) lib/bootsnap/load_path_cache/core_ext/active_support.rb:53:in `load_missing_constant'
  activesupport (4.2.8) lib/active_support/dependencies.rb:184:in `const_missing'
  lib/letter_avatar.rb:51:in `block in generate'
  lib/distributed_mutex.rb:21:in `synchronize'
  lib/distributed_mutex.rb:5:in `synchronize'
  lib/letter_avatar.rb:34:in `generate'
  app/controllers/user_avatars_controller.rb:39:in `show_proxy_letter'
  actionpack (4.2.8) lib/action_controller/metal/implicit_render.rb:4:in `send_action'
  actionpack (4.2.8) lib/abstract_controller/base.rb:198:in `process_action'
  actionpack (4.2.8) lib/action_controller/metal/rendering.rb:10:in `process_action'
  actionpack (4.2.8) lib/abstract_controller/callbacks.rb:20:in `block in process_action'
  activesupport (4.2.8) lib/active_support/callbacks.rb:117:in `call'
  activesupport (4.2.8) lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
  activesupport (4.2.8) lib/active_support/callbacks.rb:505:in `call'
  activesupport (4.2.8) lib/active_support/callbacks.rb:92:in `__run_callbacks__'
  activesupport (4.2.8) lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
  activesupport (4.2.8) lib/active_support/callbacks.rb:81:in `run_callbacks'
  actionpack (4.2.8) lib/abstract_controller/callbacks.rb:19:in `process_action'
  actionpack (4.2.8) lib/action_controller/metal/rescue.rb:29:in `process_action'
  actionpack (4.2.8) lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
  activesupport (4.2.8) lib/active_support/notifications.rb:164:in `block in instrument'
  activesupport (4.2.8) lib/active_support/notifications/instrumenter.rb:20:in `instrument'
  activesupport (4.2.8) lib/active_support/notifications.rb:164:in `instrument'
  actionpack (4.2.8) lib/action_controller/metal/instrumentation.rb:30:in `process_action'
  actionpack (4.2.8) lib/action_controller/metal/params_wrapper.rb:250:in `process_action'
  activerecord (4.2.8) lib/active_record/railties/controller_runtime.rb:18:in `process_action'
  actionpack (4.2.8) lib/abstract_controller/base.rb:137:in `process'
  actionview (4.2.8) lib/action_view/rendering.rb:30:in `process'
  rack-mini-profiler (0.10.5) lib/mini_profiler/profiling_methods.rb:76:in `block in profile_method'
  actionpack (4.2.8) lib/action_controller/metal.rb:196:in `dispatch'
  actionpack (4.2.8) lib/action_controller/metal/rack_delegation.rb:13:in `dispatch'
  actionpack (4.2.8) lib/action_controller/metal.rb:237:in `block in action'
  actionpack (4.2.8) lib/action_dispatch/routing/route_set.rb:74:in `dispatch'
  actionpack (4.2.8) lib/action_dispatch/routing/route_set.rb:43:in `serve'
  actionpack (4.2.8) lib/action_dispatch/journey/router.rb:43:in `block in serve'
  actionpack (4.2.8) lib/action_dispatch/journey/router.rb:30:in `serve'
  actionpack (4.2.8) lib/action_dispatch/routing/route_set.rb:817:in `call'
  rack-protection (1.5.3) lib/rack/protection/frame_options.rb:31:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/strategy.rb:189:in `call!'
  omniauth (1.6.1) lib/omniauth/strategy.rb:167:in `call'
  omniauth (1.6.1) lib/omniauth/builder.rb:63:in `call'
  rack (1.6.8) lib/rack/conditionalget.rb:25:in `call'
  rack (1.6.8) lib/rack/head.rb:13:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/params_parser.rb:27:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/flash.rb:260:in `call'
  rack (1.6.8) lib/rack/session/abstract/id.rb:225:in `context'
  rack (1.6.8) lib/rack/session/abstract/id.rb:220:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/cookies.rb:560:in `call'
  activerecord (4.2.8) lib/active_record/query_cache.rb:36:in `call'
  activerecord (4.2.8) lib/active_record/connection_adapters/abstract/connection_pool.rb:653:in `call'
  activerecord (4.2.8) lib/active_record/migration.rb:377:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/callbacks.rb:29:in `block in call'
  activesupport (4.2.8) lib/active_support/callbacks.rb:88:in `__run_callbacks__'
  activesupport (4.2.8) lib/active_support/callbacks.rb:778:in `_run_call_callbacks'
  activesupport (4.2.8) lib/active_support/callbacks.rb:81:in `run_callbacks'
  actionpack (4.2.8) lib/action_dispatch/middleware/callbacks.rb:27:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/reloader.rb:73:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/remote_ip.rb:78:in `call'
  better_errors (2.1.1) lib/better_errors/middleware.rb:84:in `protected_app_call'
  better_errors (2.1.1) lib/better_errors/middleware.rb:79:in `better_errors_call'
  better_errors (2.1.1) lib/better_errors/middleware.rb:57:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/debug_exceptions.rb:17:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  logster (1.2.7) lib/logster/middleware/reporter.rb:31:in `call'
  config/initializers/100-silence_logger.rb:27:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.8) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.8) lib/rack/runtime.rb:18:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/static.rb:120:in `call'
  actionpack (4.2.8) lib/action_dispatch/middleware/static.rb:120:in `call'
  rack (1.6.8) lib/rack/sendfile.rb:113:in `call'
  lib/middleware/missing_avatars.rb:21:in `call'
  lib/middleware/turbo_dev.rb:34:in `call'
  rack-mini-profiler (0.10.5) lib/mini_profiler/profiler.rb:171:in `call'
  message_bus (2.0.2) lib/message_bus/rack/middleware.rb:62:in `call'
  railties (4.2.8) lib/rails/engine.rb:518:in `call'
  railties (4.2.8) lib/rails/application.rb:165:in `call'
  railties (4.2.8) lib/rails/railtie.rb:194:in `method_missing'
  rack (1.6.8) lib/rack/urlmap.rb:66:in `block in call'
  rack (1.6.8) lib/rack/urlmap.rb:50:in `call'
  rack (1.6.8) lib/rack/content_length.rb:15:in `call'
  puma (3.9.1) lib/puma/configuration.rb:224:in `call'
  puma (3.9.1) lib/puma/server.rb:602:in `handle_request'
  puma (3.9.1) lib/puma/server.rb:435:in `process_client'
  puma (3.9.1) lib/puma/server.rb:299:in `block in run'
  puma (3.9.1) lib/puma/thread_pool.rb:120:in `block in spawn_thread'

Following that error are the related error traces for the missing images. Essentially, it seems as though the image size it’s looking for isn’t being created on startup.

I tried rm -rf tmp and restarted locally but that made no difference.

UPDATE: I ran the sidekiq job for CreateMissingAvatars thinking that may help. It did bring in the system user avatar but it applied that to my user account as well. I would have expected a letter avatar instead. But maybe that resolved it?

UPDATE2: Sorry. Not resolved. Here’s the error:

No such file or directory @ rb_file_s_ctime - /Users/joebuhlig/Codebase/discourse/tmp/letter_avatars/5_9923d3d1b8ee4d0450f1275952f90f00/J/185_229_243/64.png

This to me sounds like a Ruby version thing… can you raise this on the bootsnap GitHub repo.

My guess, somehow you had version 2.2 installed, you started Discourse and built the cache in tmp/cache later you started running Ruby version 2.3 and it tried reading the 2.2 cache.

My first port-of-call would be rm -fr tmp/cache

If you need to workaround for now comment out bootsnap in app/boot.rb


Hi Sam,

I have been using ruby 2.3 as per dev install guide. Cleaning cache, installing dependencies and rerunning with ruby 2.3 did not work for me however commenting out bootsnap worked.

I will check on bootsnap thing, as you suggested. If I find solution will post it here.

Thanks for quick workaround. I am huge fan of discourse and team.


@joebuhlig I just encountered the exact same issue in my native OSX dev environment (I even also have a new MacBook Pro :slight_smile: ).

Changing my imagemagick version fixed it for me.

  1. Following the breadcrumbs, I noticed that imagemagick plays some kind of role in the naming of letter avatar files (here).

  2. Discourse core is still using imagemagick 6.9.x

  3. I was using imagemagick 7.0.x (current stable homebrew version).

    /usr/local/Cellar/imagemagick/6.9.6-5 (1,493 files, 22.5MB)
    Poured from bottle on 2016-11-20 at 00:08:07
    /usr/local/Cellar/imagemagick/7.0.6-4 (1,522 files, 22.7MB) *
    Poured from bottle on 2017-07-31 at 07:43:44
  4. I switched to the 6.9.x version homebrew kept (see above)

    brew switch imagemagick 6.9.6-5

Now letter avatars work as normal. No annoying errors.

54 AM

cc @sam


Got it! That makes a lot of sense. I never took the time to dig much further into it.

How did you install the older version of IM? It seems homebrew can’t find the 6.9.x formula when I run it.

EDIT: I hate it when I find the answer after asking the question.

I had to unlink it, install with a gist I found online, and then switch it. So:

  1. brew unlink imagemagick
  2. brew install
  3. brew switch imagemagick 6.9.7-10

For anyone else who runs into this same issue on Arch, the current imagemagick6 release will work, but imagemagick 7.x (current) still isn’t compatible… Specifically:

pacman -R imagemagick
pacman -S imagemagick6

Restart your rails server and all will be working fine.