Strange ONEBOX issue

When I post this link in my forums after it first renders appropriately.

actual link below here: https://neo.life/2022/07/the-buck-institute-where-the-promise-of-aging-research-isnt-longevity/

but then a few seconds later I get get a broken link symbol, so, it looks like this in my forum:

Weird, does this work on try.discourse.org?

image

Edit: I believe this is an issue with your site.

No - it also happens here:

This link is here: https://neo.life/2022/07/the-buck-institute-where-the-promise-of-aging-research-isnt-longevity/

but then if I put it on its own line:

2 Likes

Something is certainly off here, we will have a look. Maybe the host is rejecting the user agent for our backend crawler.

1 Like

When accessing the image (https://neo.life/wp-content/uploads/2022/07/buck-institute-longevity-aging-genetics@2x-1000x714.jpg) programatically (e.g. via curl), we get served a Cloudflare error page with a captcha. So it looks like this site is deliberately blocking robots from downloading the images.

If you trust the site and are happy for images to be permanently hotlinked, then you could add neo.life to the disabled image download domains to stop Discourse attempting to download them.

3 Likes

Interesting… I tried to do what you suggested (adding neo.life to the disabled image download domains), then opened the post and re-saved it , but the problem is still evident.

Do I need the http:// in front of the domain for it to work properly?

I’m seeing this onebox issue on more and more links lately - another example:

Same thing happens - it renders, then it doesn’t.

1 Like

To fix an existing post after changing the site setting, you’ll have to click the :wrench:, then “Rebuild HTML”. I just did that on your post above and it’s looking ok here. Can you try that on your site?

This one looks like it has a slightly different cause. I’ve tracked it down a problem in one of Discourse’s dependencies. We’re tracking this, and will try to get a fix or workaround in place. Thanks for the report!

1 Like

Another example - yes, the rebuild HTML worked in that last case:

But here is another example where I’m getting the broken link image for a respectable sourced link:

Even if the site is considered respectable it doesn’t mean that they’re going to allow images to be crawled and downloaded by bots.

2 Likes