Text editor is not working in Firefox 78?

Hi there, it seems to be an issue with last update. I tried to upload a video but it seems uploading is broken too.

When I try to use buttons on editor (or upload) in Firefox I see some errors on console regarding to Discourse chat:

I disabled all extensions and stills not working. Tell me if I can help you with something more as user :slight_smile:

1 Like

Odd, is this still happening now?

Is it only related to videos, can you repro with images?

Here we go: https://ufile.io/z1tybnhf

[MP4 ~5MB file]

Hmmm I am unable to repro with that file? (using Firefox on Linux)

Well, you need to download the MP4, read the first image or reproduce trying to bold your text in Firefox and Discourse.

This is a bold text with keyboard shortcut

This is a bold text with the menu click

Nope, no repro in Firefox for me.

link broken in firefox lol

I cant repo on firefox on windows 10.

Yeah you need the exact right codecs, removed

1 Like

That’s a bold tried with buttons.

That’s a bold tried with keyboard.

Sorry but I’m still with the same (without extensions).

Well I recorded with Kazam, but it’s OK:


No luck reproducing here, just tried on firefox on linux. Perhaps try the browser safe mode? Maybe it is browser plugin related.

Regarding that error, it looks somewhat unrelated and I think we fixed it a few days ago.

1 Like

What version of Firefox are you using? Are you using an ESR release?


78.15 ESR, what’s up with that?

Still not working in safe-mode.

I am not sure if we even had 78.15 in our test matrix.

I think we need to improve our page here to at least call out stuff a bit better:

Depending on one’s interpretation Firefox ESR is either supported or not. We need to make a proper call here. (if unsupported we should display the HTML view)

My guess here @david is that this may be related to the undo support?

1 Like

Firefox 78 ESR support ended last year from Mozilla. It doesn’t receive security patches anymore. You need to update to the current ESR version (102) or at least the previous one (91) which will be supported for two more months.


I just double checked via BrowserStack, and the toolbar formatting buttons work correctly under Firefox 91 :ok_hand:

Yeah, via MDN, Firefox < 89 had bugs with text manipulation:

Before Firefox 89, manipulating the content of <input> and <textarea> elements using Document.execCommand() commands requires workarounds (see bug 1220696).


We run CI on every commit on Firefox ESR. ESR version is the one packaged in the current Debian stable. At the moment it’s ran against 91.11.0.


Can we feature detect 89 and lower so it gets html view without impacting supported browsers?

1 Like

It’s difficult to feature-detect a bug like this, so I think our only option is to check the user agent:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.