Uploader is stuck at 100% on a Firefox fork

FIles are not uploading from my pc. I had to upload images, videos, etc with my phone, which is not great. What is going on?

where are you uploading it too ? meta or a private site ?

If it is a private site, then contact the supplier.

1 Like

it’s working here (Firefox 96.0.3, Win10)

ps. but yes I’ve had some transitory non reproducible trouble yesterday with a webp, on a 2.9.0.beta1 ( eff0106efb ) site


@IAmGav Neither meta nor private site

It is a different community based on discourse
The bug is also in this meta

@Benjamin_D That community was not running a beta stage. Plus I didn’t create that community! :wink:

If you want more details. I can give you my user agent:

Mozilla/5.0 (Windows NT 5.1; rv:71.0) Gecko/20100101 Firefox/71.0 Mypal/29.3.0

Windows NT 5.1 is Windows XP. This issue is happening on old firefox!

@IAmGav and @Benjamin_D forgive me if that sounded mean :frowning:

Please contact them and don’t post it here. It has nothing to do with meta.

Pretty much it is happening all over discourse-based communities! and in this meta too!

You’re saying that you can’t upload images here or to try.discourse.org with your desktop? If that’s the case it’s likely that it’s an issue with your browser. Have you tried another browser? Incognito mode?


Incognito mode on the browser I’m using still doesn’t fix the problem!

My suggestion is to upgrade your device.

1 Like

no i cant do that unfortunately

As far as I know, very old browsers/operating systems aren’t supported by Discourse.


why? how is that?

not everybody can afford the best hardware!

There are limits to what can be supported. It’s a design decision, and at some point the effort required to support is software that few people use is too great.

If you must use hardware that won’t support a supported version of windows, you can usual Ubuntu.


ughh. seems like i have to use the laptop for discourse :frowning:

When there is a will, there is a way

I always believe this quote. So maybe i can try by hosting the image and interpret the link as the image :slight_smile:

You already got the answer, so I’m bacically just wasting bandwidth and fightinn against nagger of Discouser, but…

This isn’t matter of the best hardware. It is matter of really old and outdated software and if some hardware can’t use any newer browser (out there is some lightweight options too) it is badly outdated too — and it is not something like iPhone8 vs. IPhone13 but trying to use 10 years old Nokia.

Discourse is not the only platform that not supports browsers that old. Actually really many services don’t work any more with IE5.1/XP.

I don’t know how things are word wide but in northern Europe all user agents, same as you are declaring, are 100 % only bots.

1 Like

@Jagster I am not using IE! It will not load even the barebones of the website :rofl:

So I tried hosting the image and use the link as the image and it worked!

#off-topic Image Host Site Recommendation: https://www.catbox.moe/

MyPal is a fork of an extremely old version of Mozilla Firefox.

The official GitHub page for the project indicates that it’s been abandoned for one reason or another (although it looks like a new version based off of Quantum is (or was) in development).

As a result, I agree with everybody else in this topic. You’re going to have to use a newer operating system or switch web browsers. Very few web browsers support Windows XP nowadays, but Basilisk is an option.

Supporting outdated web browsers and unsupported operating systems that very few people use nowadays is (understandably) not a priority for Discourse.


my system will show an extreme bsod if i upgrade the pc

so let me stay as i am staying

i got the solution and thats it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.