Theme Creator appears to be broken: "requested URL or resource could not be found"

I’ve been having an issue with the Theme Creator since at least Monday.

tldr; all methods of adding/creating a new theme result in the same error message:

“An error occurred: The requested URL or resource could not be found.”

My issue: I had been working with a theme that I uploaded last week and was editing within the Theme Creator. So I know that the theme I used is valid.

On Monday I logged in to theme creator, and even though I was logged in, I was getting an error message related to permissions when trying to edit.

As a result I simply deleted the theme and tried to re-upload. At this point I received the above message.

Initially I thought it was just my theme, but after checking it over I didn’t see anything. So I tried the other options (Popular, Github and Create New) and got the same message for every method.

Please advise.


can confirm i’ve had some issues lately and generated same error message. i find uploading the themes has been more consistent than the github repository links even if i just download them from there then upload.


Yeah I really wish any options were working for me right now…


Hmm you need to be a member of the theme_creator group here on Meta to get access to upload themes to theme creator, and it doesn’t look like you were part of the group (were you ever? :thinking:).

:point_up: Nevermind, that’s just to share themes.

Could you try logging out of theme creator, logging back in, and try to upload again?


I’ve logged out/in and also tried logging in with incognito window.
Still no option works: not installing a Popular theme, uploading, from a git repo, or even just creating a new one…


It does appear like I’m part of the Theme Creator group?
Perhaps there is something wrong with my permissions?


Yeah that was my mistake, you only need to be part of the group to share from theme creator, anyone with an account should be able to upload. We’ll investigate the problem and try to figure out what’s going on.

Yes, it seems the plugin we’ve built might need an update… it appears to be a permission issue that impacts multiple accounts.


Looks like this was caused by some recent refactoring in Discourse core. I’ve opened a PR with a number of fixes:


These fixes were deployed to yesterday - please let us know if you’re still running into any issues


It’s working again, thank you!


This topic was automatically closed after 3 days. New replies are no longer allowed.