Theme Creator Broken Again?

A while ago I’ve experienced issues when editing themes/uploading it to Theme Creator. Got fixed sometime, but the issue came up again. When I tried installing/uploading a theme it gives the the error: You are not permitted to view the requested resource.

Checked console logs. Is this some issue with Theme Creator only allowing admins to upload? Definitely permission-related.

1 Like

Are you saying you are seeing this screen with a user who is not an admin ? Are you sure of this?

Can you explain, is this error showing up on your site? Are you an admin on your site?

I think @Chaboi_3000 is talking about, which allows regular users to create/manage their own themes.

I’ll take a look :eyes:


Yep, was talking about the Theme Creator. Sorry for not making it clear.

Any updates on this? I’m still experiencing this issue and it’s quite frustration considering I don’t have an instance installed on my new computer.


I’m experiencing the same issue, after following the tutorial for themes .

I even registered with two new accounts and both of them get the same issue.

It seems like I don’t have permissions to upload the theme.


1 Like

Sorry this issue has been open so long! I just pushed a fix for an issue with git themes - can you try again and see if it’s working ok @Chaboi_3000 and @akapetzoglou1


For me it worked now! Thank you @david :rocket:


@david I can confirm it’s fixed and working :tada: Thanks for the time!


This topic was automatically closed after 5 days. New replies are no longer allowed.