Topic List Previews

It doesn’t seem like feature image is working for me. I’ve done the following:

1, Set feature image tag
2, Enable featured images for non-category routes.
3, Click apply featured images site setting to all categories.
4, Check show featured images above topics.
5, Go to certain post and add that tag
6, Go see all pages yet nothing happened.

What am I missing?

EDIT: Also, when setting feature tag, it doesn’t read any of my existing tags. I can only create new ones. Is that the problem?

1 Like

There appears to be a restriction with Discourse. The tag picker will not allow you to select tags that meet certain criteria . @davidkingham came across this. See Tags restricted to a category are not available to plugins or components

Can you please clarify if you are using the experimental theme component or the plugin?

1 Like

The Experimental Theme Component has just received some love.

I’ve added:

If you don’t have the sidecar plugin installed, the thumbnail picker and actions are both now hidden so TC only users don’t get any errors or are confused!

1 Like

Are your existing tags restricted to categories? This is a discourse limitation and I brought up the issue here Tags restricted to a category are not available to plugins or components but have not received a response unfortunately. @merefield were you still planning on switching this field back to what it was so we can get around this limitation? This is the only reason I can’t switch over to the TC right now. Thanks!

BTW, the working actions seem to be working well!

3 Likes

What alternative? You can’t compare it directly with plugin settings unfortunately.

I’m pretty sure it was a text field when you first released the TC, you mentioned you could switch it back here Topic List Previews

3 Likes

Oh I could revert it to text but that defeats the option of having a nice quick verified list.

But you are right I could switch it temporarily.

3 Likes

Thank you Robert for your hard work to make it compatible with the new theme component manager. That’s outstanding !

3 Likes

Just coming back to report that my problem is solved.
I simply deactivated the plugin and tried the theme component version.
It seems to be working neat! I can also pick my existing tags now.

Thank you for your hard work.

3 Likes

I have some more feedback on the theme component:

  1. Will you be adding the svg feature for the default thumbnail that is in the topic preview component? I’ve been using an image of an svg which is not great for dark/light themes.

  2. Topics created with the wordpress plugin do not have thumbnails, nor can one be selected (see this category), I’m guessing it’s related to this, but it did work with TLP plugin, so maybe it’s a core issue now.

  3. Bugs with other plugins - FYI the locations plugin is currently breaking thumbnails on desktop (this just started with the latest updated today) and the events plugin is breaking thumbnails on mobile, so these need to be disabled for the component to work currently. I’ll report these bugs appropriately later, I just wanted to make everyone aware since it took me a while to figure this out.

2 Likes

No plans to at this stage. I believe supporting a default thumbnail is an important differentiation to the SVG option. Perhaps I could offer both at some stage.

Yeah it’s likely to be a core issue.

Thanks for the report. That’s interesting!

3 Likes

I’ve just had a user run into this as well - I’m a little torn on how to proceed (I agree with your reasoning, and its taken this long to come up, so it still seems quite rare). Do you think it’s possible to inject an error in this user flow that says something like “Gif too large”?

I feel that this is the user mis-using the system, and therefore the failure should be educational to them, where as a 500 error just looks like we screwed something up.

1 Like

Hope it is okay to bug report.

The featured image on the top sometimes updates and shows a newly tagged image but sometimes it doesn’t. I am still using the older plugin. Is it recommended to use the new theme component and sidecar plugin?

2 Likes

@merefield So we’re in the ‘5 day upgrade window’ now if I’m not mistaken. Is TLP ready to roll?

1 Like

Sorry, I’m working on another plugin atm. It was just days ago but not had chance to recheck. I’d only upgrade it now if you can check the upgrade first in a staging environment. I’ll get to it soon. I’ll extend the support period in compensation.

3 Likes

It’s now safe to update Topic List Previews plugin. I’ve brought it up-to-date with latest core codebase. Featured Images is working correctly.

I will be supporting the build over the next 5 days in case there are any additional breaking changes from core.

Known issue: on Desktop Firefox, the masonry (tiles) layout is glitching slightly on load. This doesn’t affect Chrome, Safari or mobile. I will look at this a bit more next week. If you really hate it, try the TC.

3 Likes

Seeing the same problem with the latest update to the old plugin. Haven’t tried the theme component yet.

2 Likes

You going to have to provide detailed step by step instructions (STRs) to allow me to reproduce the problem.

1 Like

I updated discourse and also TLP.
Discourse is at 75b1298e99
TLP is at 97c56af

When I tag a image with “featured” tag (restricted to only staff members, so that only staff can tag but others can see this tag) it doesn’t get populated on the featured image row at the top.

If you see here - Topics tagged featured there are some images which are not shown int he top row. I have also tried rebaking the posts but it doesn’t help/

When you tag them, there is momentary flicker at the top row suggesting that something is reloaded but the image thumbnail don’t show up.

Hope this is helpful.

2 Likes

Unfortunately haven’t found any way to easily replicate the problem as of yet. The only commonality found so far is that it only seems to effect topics added within the last month. Works fine with older topics, but with anything recent, tagging featured fails to display at the top. To clarify the problem was also in the version prior to the latest update to the plugin, and started after the May updates to core. Thumbnails are generating for category views for the effected topics, the only thing not working is the featured tagging.

4 Likes