Trust level changes while automatic groups do not change

Continuing the discussion from Change all exsisting users to trust level 2:

I used the above lines to change the trust level of bulk users, and it worked. So now all of the users in our forum are let’s say tl0.

  1. but when I check the automatic groups, I see users are still in trust_level_2.
    how can i change trust level in bulk?

  2. also some of the users got locked in term of trust level. I mean when i go to that user in admin panel, I see the trust level is locked.
    what’s happening here? and why do they get locked?

I’ve noticed this as well when moving users between TL0 and TL3. The users are locked so they can’t automatically progress further in trust based on the assumption that you changed their trust level for a reason.

As an example, say you have a user you achieved TL2 by participating for >15 days. They did something that warranted you setting their TL back to 0. If their TL wasn’t locked, based on automatic promotion they would move right back to TL2 as they meet all the requirements.

1 Like

The group issue has been solved as time passed. and it seemed that the system needed some time, ~ 12 hours.

now users in the trust_level_i group are exactly in tl_i.

about the trust level lock, is it a bug or is it meant to be like this?

Right, the groups are fixed on a daily scheduled job.

And yes, the locked trust level is supposed to work like that. But because you elevated them to 2, you can clear that field.

1 Like

Thanks for the answer,

there’s one single concern about the locked trust level:

if one change the trust level via rails console, then some of the users may get locked during the process, and you can’t understand it unless you check the user profiles in admin panel one by one.

is there any command to unlock bulk trust levels via rails console?