Trying to install Discourse in an Ubuntu VM on Proxmox

Hello Discourse community,

So I’ve successfully installed Discourse on an already set-up VM as well as on a physical server box. However, recently I bought a PowerEdge R710 and want to set up a Discourse forum in an Ubuntu Server 18.04.2 LTS VM. I’ve installed Proxmox for VM Management.

So I’ve been following this article. and everything has been going well … until I perform ./launcher start app

As it begins, I eventually receive the message no space left on device (pardon the small image sizes, since the Proxmox VM screen is small on my PC):
Clearly the issue should be obvious. I ran a df -h and received the following:

Now you would think I only assigned 5 GB to the VM, but I actually assigned 100 GB, as GParted shows:

So, where would I have assign the extra disk space to get Discourse to run? And I’m just talking about locally within the VM.

Why are you following a third-party installation guide?

We can only support installations here which follow the standard install guide.

If you want to use that guide then you consult its author, alternatively you can follow the supported standard install linked above.


Its basically the same guide as the Standard Install Guide, just without the Cloud steps (so starting from the Docker steps). I’m not looking to host this server in the Cloud (so not following them), I’m looking to host it in a VM on my server.

And the main Guide does not suggest what to do in case I run into a disk space issue like this. That’s why I’m asking here where would I have assign the extra disk space to get Discourse to start properly.

More has to differ between your local server and a vanilla Ubuntu VM for you to be seeing that error.

We make a best effort here to support the standard install. The assumption is that if you choose to alter elements that you have the necessary expertise to do so.

1 Like

The LVM physical volume (sda3) is 99G, but most of that space is not allocated. You need to use lvresize to make ubuntu—vg—ubuntu—lv bigger. Don’t forget the -r flag to also resize the filesystem.


@schleifer Thank you for answering!

How do I go about using lveresize? I’m not familiar with resizing partitions.

Looking at some other code examples online, I assume something like this?
lvresize -r +99G /dev/mapper/ubuntu--vg-ubuntu--lv

Does lvesize know to take the 99 GB in /dev/sda3? More clarity would be helpful.

-l +100%FREE


@schleifer I got it! I did the following:

sudo /sbin/lvresize -l +100%FREE /dev/mapper/ubuntu--vg-ubuntu--lv
sudo /sbin/resize2fs /dev/mapper/ubuntu--vg-ubuntu--lv

/dev/mapper/ubuntu--vg-ubuntu--lv now has 90 GB! I also got the Discourse Setup to come up in my browser (localhost)!

Of course, I’ll still need to figure out how to set it up so Discourse can be accessed outside the VM, which will be a new challenge for me from previous installs, but I’m glad I’ve gotten this far in 2 days.

I will likely post more progress here if I run into any more issues :slight_smile: