Trying to install plugin (But not working)

Can you please just tell me how i can install a plugin step by step

i tried with this Install Plugins in Discourse but didn`t work.

Thanks

Can you be more specific about what is going wrong?

1 Like

I will yell you what am doing step by steep

i’m in my vps by SSH
i started with cd /var/discourse then ENTER
then i wrote this nano containers/app.yml and ENTER

am getting a very long menu, i dont now where i have to put this code

hooks:
after_code:
- exec:
cd: $home/plugins
cmd:
- mkdir -p plugins
- git clone https://github.com/discourse/docker_manager.git
- git clone https://github.com/discourse/discourse-solved.git

because i want to install solved plugin

Please if you want to help me write it down step by step so i can make it. sorry am new on this.

Scroll down until you get to the first line “clone” in it, the docker_manager one.

type control-K to kill (cut) the docker manager line, then control-u twice to paste it back in twice. (Spacing is very important, so copying and editing a line that you know works is a good precaution).

Then, on the second line, delete the docker_manager URL and add the URL for the solved plugin.

Then control-X to exit and ./launcher rebuild app.

2 Likes

Sorry i did`t get it. @pfaffman
see the picture of what am getting.

You’ll need to scroll down using the arrow keys.

That`s all, you see the bottom of the page.
am trying to scroll more than this but this is the end of the page.

Sorry, yes i used the arrows.
i was trying the mouse… sorry again.

1 Like

Ok i pasted, the docker manager is double one under the other… whats is next ?

Follow the above instructions, using only the arrow keys, not the mouse.

Yes, now looks like this, do i need to delete the second line and paste the Plugin clone ?

Yes i made it :smiley::smiley:

Thanks A lot @pfaffman and also @jomaxro

in fact the installation of the software and setting the mail server is easier .

Thank you

3 Likes