Unable to Add Edit Reason on Mobile

After I edit someone’s post on desktop I always have the “Add Edit Reason” if I want to add a reason for my edit. I usually do so, but I usually moderate on mobile and don’t have that option.

Make sure you are on the mobile version and, as a moderator, just click on the edit pencil to edit someone’s post. You will not have the option to add an edit reason.




Have you tried “desktop view” in the hamburger menu?

I don’t know, but to get back to mobile view you may need to append
?mobile_view=1 to the end of a URL

1 Like

Yes, I can do that and do, do that. A problem with that is I can’t see what I’m typing then. That makes it a pain when I type the wrong thing, because then I have to go back and re-edit just to add the reason again.

Ah, that’s not good.

Maybe a simple CSS tweak? Though real estate is at a premium for mobile, which AFAIK is why the option isn’t there in the first place.

Do you think reducing the height of the composer input is worth it to make room for the edit reason?
Maybe only with the preview pane hidden?

I just moved this to #feature and added #pr-welcome

I am open to getting this to work on mobile, but want to see some example screenshots first on the proposed implementation.