Unable to disable "Illustrate Post" in AI post options

I could be missing something here, but it appears that I cannot opt out of the new “Illustrate Post” option without disabling AI completely. I see that Illustrate Post was recently added to the post AI dialog in the last couple of weeks. However, it uses Stable Diffusion which I am not interested in enrolling in at this time. So it is broken and results in a 500 error when my users try using it. So I would like to disable it and I am not finding a setting for that. Failing to find a specific setting to disable it, because I have disabled Stable Diffusion in my AI settings, I am confused why this Illustrate Post setting is still shown. Intuitively, if I do not have Stable Diffusion enabled, this dependent feature should not be visible. Given this, I am reporting this as a bug.


We will fix this

Option should be optional
You should be allowed to pick Stable Diffusion vs Dall E vs nothing
If no key, it should be off

Cc @Falco / @keegan


@Hifihedgehog Thanks for submitting this issue. This should now be resolved :tada:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Just an update on this:

We’ve added support for Dall E as an option as well, so there is a new plugin setting (ai_helper_illustrate_post_model) in which the feature is dependant on (disabled by default):