"Unable to generate a preview for this web page because the following oEmbed / OpenGraph tags could not be found: description, image"

Hi there, I’m trying to figure out why .webp images aren’t being oneboxed on my instance, whereas they do work here on Discourse Meta. For example, this one:

On my instance it throws an error in the preview:

“Sorry, we were unable to generate a preview for this web page, because the following oEmbed / OpenGraph tags could not be found: description, image”

I don’t care so much about the preview, but it is a problem that it’s only generating a link to the image and not actually displaying it. I don’t understand why it works here and on other Discourse forums I use, but not on mine. The only relevant setting I can find is:
authorized extensions = jpg, jpeg, png, gif, webp, pdf

Hmmm :thinking: that looks like this:

Hmm interesting, thanks. It looks like the same symptoms, but I don’t think it’s the same cause. I’m not using a proxy, and at any rate all the .webp links I’ve tried work here but the same ones fail on my forum.

When did you update your discourse version? There was a fix yesterday


Wow, what a coincidence! I was about a 7 or 10 days behind the latest commits. I just updated, and all of the new images I’ve tested seem to work:




However the URLs that I tried previously seem to be cached or something, because they’re still giving the same error.

You will need to rebake old posts with those links for it to onebox.

Hmm, no, I mean trying to create new posts with those same URLs I was testing before are throwing the same error.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.