Unable to keep desktop push notifications enabled - dup2

Hey folks,

I am finding that the push notifications package for desktop is bugged. I have having the exact same issue shown in this video from this older post:

Per @Falco:

I am reporting this bug. Anyone able to help with this?

Hey folks,
Anyone seeing the same thing as I am seeing here?

Also, not sure if this is how to bounty program works, but we can put a bounty on this to get it fixed.

The bounty program is strictly restricted to security issues. If you wish to sponsor someone to look at your bug your could try a topic on #marketplace

@Falco is aware of this topic and will have a quick look when he has a chance.

Hey @sam Sorry about that. I wasn’t sure how that bounty program worked. Thanks for the clarification. Glad you guys are looking into it. Cheers!

On the video the user had already enabled “non-push” notifications and only checked the “push” notifications checkbox, which won’t work indeed.

If you do “check” the checkbox for push notifications on desktop, and then Disable → Enable notifications, it will persist and work on my testing.

If it’s not working for you I will need cleared reproduction steps. Can you reproduce this here on Meta?

Thanks @Falco for looking into this. This is a video of my attempt at checking the checkbox of the push notifications on desktop in firefox. I tried checking the box and then disabling the enable notifications as well as all the other combinations.

Here is the screenshot of all the plugins we have installed as well as a screenshot of showing that we have the push notification plugin enabled.

Are we doing something wrong or missing something? or is it an issue with the package?

I logged into your website and I was able to enable notifications right away:

However there is indeed a cosmetic bug on persisting the state of the checkbox because the custom user field is not coming on the current user payload.

4 Likes

Hmm that is so strange. I tested with a colleague and we did exactly what you did and we even sent each other messages, but we did not get what you got. Here is the clip:

By the way, here is a screenshot of our bowser settings, as you can see notifications is turned on and permissions allowed for the site:

What do you think it could be?

That’s an incognito tab? That won’t work.

Also, on desktop Firefox you will need to have the browser open in order to get the push notification, as Firefox doesn’t have a background service for it when the browser has no open windows.

1 Like

We tried Chrome, IE, and Firefox. On each we tried incognito and no incognito. We also tried on three different computers. It was all the same. I’ll have my colleague share another video showing the us doing this on Chrome with no incognito.

Can you reproduce this bug here on Meta?