Unable to run /launcher rebuild app [solved]

I have received this while trying to upgrade to latest version. Any help would be appreciated. I tried to run from local username with sudo, and also as root. Nothing helped.

`    /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/rake-12.3.2/exe/rake:27:in `<top (required)>'`
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => assets:precompile
(See full trace by running task with --trace)
I, [2019-03-21T16:05:48.258104 #13]  INFO -- : Purging temp files
Bundling assets

I, [2019-03-21T16:05:48.258334 #13]  INFO -- : Terminating async processes
I, [2019-03-21T16:05:48.258551 #13]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/10/bin/postmaster -D /etc/postgresql/10/main pid: 68
I, [2019-03-21T16:05:48.258606 #13]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 184
184:signal-handler (1553184348) Received SIGTERM scheduling shutdown...
2019-03-21 16:05:48.258 UTC [68] LOG:  received fast shutdown request
184:M 21 Mar 2019 16:05:48.259 # User requested shutdown...
184:M 21 Mar 2019 16:05:48.260 * Saving the final RDB snapshot before exiting.
2019-03-21 16:05:48.324 UTC [68] LOG:  aborting any active transactions
2019-03-21 16:05:48.327 UTC [68] LOG:  worker process: logical replication launcher (PID 77) exited with exit code 1
184:M 21 Mar 2019 16:05:48.327 * DB saved on disk
184:M 21 Mar 2019 16:05:48.327 # Redis is now ready to exit, bye bye...
2019-03-21 16:05:48.328 UTC [72] LOG:  shutting down
2019-03-21 16:05:48.656 UTC [68] LOG:  database system is shut down

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile' failed with return #<Process::Status: pid 3963 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"assets_precompile", "cmd"=>["su discourse -c 'bundle exec rake assets:precompile'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Are you using any custom plugins?

No, this is a 1 year running config with plugins from official plugin repository. I never had issues in past upgrading this.

We need a few more lines of that log to be able to help you.

1 Like

Do you have the custom-wizard plugin installed? There is an issue with that at the moment. If not, please can you post your list of plugins here - as @Falco said we need some more information before we can help further.


what is the more info one needs? yes i have custom-wizzard.

problem solved on latest rebuild.