Unable to save adsense settings

I would like report an issue I encountered and the only resolution I could find.

This has happened twice so far. First time when I installed the AdPlugin, rebuilt discourse and went to the admin Settings page -> Adsense -> adsense topic list top code and I tried to enter the ad unit code, it wouldn’t let me save it. I would click on the green check box and nothing would happen. Tried to reload the settings page, same results. Infact I couldn’t save any ad unit codes on that page.

Solution: Restart the server, worked just fine, I could save any changes to the AdSense page

Today, after about a week of running, I wanted to make some changes, mid last week I had removed the ad unit code from adsense topic list top code and today I wanted to put it back. Same issue, it refused to let me save it. I could change settings in other parts of discourse but it wouldn’t let me enter or change any ad unit codes on the AdSense page.

Solution - Restart the server

It couldn’t be co-incidence that it happened twice, weeks apart. It only seems to impact the ad unit code.

If anyone has any suggestions it would be welcome, I don’t think restarting the server each time is a happy solution.

I’m running: v2.3.0.beta9 +468

1 Like

Disable your ad blocker.

4 Likes

Yes, it’s disabled, I double checked that.
Would an ad block would affect the ability to Save the admin AdSense settings? It’s not an issue about displaying the ads, the ads are being served but I’m unable to make changes to the configuration.

Yes, ad blockers can definitely mess with the ad settings. Some block HTML elements or scripts with the word “Ad/Advertisement” in them entirely. It’s hard to pin down if the problem is inconsistent, but that’s often the culprit.

If you run into the problem again, it would be helpful if you could check for any errors in the console in your browser’s dev tools.

6 Likes

I’ll ensure that the adblocked is turned off. If it happens again, I won’t restart so we can debug it a little more.

3 Likes