Unable to save invite when email address field is filled in

Version 3.1.0 Beta 1

Steps to reproduce:

  • Go to Admin > Users > Send Invites > Invite
  • type in email address for restriction
  • add topic
  • Add to group
  • Set expiry to 2 weeks

Expected Result:

  • Able to save invite. Can copy link into formatted email, etc.

Actual Result

  • Cannot save invite. Cannot generate link.
  • Save invite button doesn’t respond
  • Save and send email button doesn’t respond.
  • CAN generate link without an email attached. (not a valid workaround as not secure and we have sections under NDA)

Additional notes

  • Our IT department has enabled login using an existing profile login to a different website that we have. As in our users have accounts for our sales website. They can use that same login to get into Discourse. The login button redirects to our sales website’s login where the user inputs their information and then they are redirected back to Discourse (logged in).
  • This was previously working but has not been working for about 3 months now, the last working version definitely had a 2.x version number.

Hello Logan! :slight_smile:

I couldn’t reproduce the issue. I followed your steps and clicked :link: Save Invite:

I’m using Discourse 3.1.0.beta2. Could you try again after updating Discourse?

Is there any error in your browser’s dev tools console when you click the Save Invite button?
Is there any error in /logs/?

Hi @Canapin, thanks for your response.

I’ve managed to figure out the cause of the issue, this can be closed.

When a user already has an account, the save invite option no longer works. It used to prompt and say “There’s no need to invite X, they already have an account”… I think this is a much more elegant solution than just making the button no longer work.

Many thanks, all the best, Logan

Edit: just to confirm, I didn’t find any error in either of the locations you suggested.

I believe a proper error is in place now so that should help: :+1:


This topic was automatically closed after 20 hours. New replies are no longer allowed.