Unable to select groups in data explorer

I’m not able to use the new feature to allow certain groups to access queries. What am I missing?

Discourse 2.4.0.beta5 Release Notes

discourse-data-explorer

  • Allow groups to access queries

I have this box in Data Explorer:
image
But it doesn’t work- for example if I type “moderators” (with no quotes), it doesn’t search or auto-complete, and if I save the query and come back to it, the box is empty again, and moderators do not have access to the query.

I’ve tried other groups as well- the problem is not specific to moderators.

I don’t see any related settings- only the setting is to enable Data Explorer.

1 Like

@markvanlan any ideas about :arrow_double_up:

1 Like

If you’re self hosted, Did you upgrade both discourse and the data explorer plugin?

1 Like

I am not able to reproduce this locally, and group selection is working here on meta.

Even if Discourse was not updated when the data-explorer plugin was, the groups should still be able to be added.

4 Likes

I did ./launcher rebuild app. I saw it pull the plugins, watching the console.

1 Like

Are you on the stable branch?

2 Likes

I’m using 2.4.0.beta6.

Any non official plugins installed?

Yes, but realistically this isn’t a high enough priority to start eliminating plugins and css customisations, if it’s working for everyone else.

You can first try by using safe-mode. You could use this mode of safe-mode:

http://www.example.com/?safe_mode=no_custom%2Conly_official

If you can still repo with this, then it’s not from a non official plugin, and this test won’t impact your users.

2 Likes

Nice. But I can still repo. Found this in the console, both with Chrome and Firefox. Will try to drill down further tomorrow, but I’m a bit out of my depth here.

1 Like

seems like select-kit related I will have a look.

1 Like

That should fix it (you will need to pull the last version of the plugin):

For some reason group_ids were retrieved in 3 formats : nil, [], ""… and select-kit had troubles looping over ""

The important fix is in plugin.rb, but I also tried to make it more resilient at other parts of the code.

@markvanlan I imagine some version of this code were buggy at some point and created some corrupted data like this? Feel free to dig more if you think there’s something to change/migrate.

I also made a few other commits while I was at it:


5 Likes

This topic was automatically closed after 33 hours. New replies are no longer allowed.