Undefined method `resolve_baked_field` when precompiling themes

What would be a good method to diagnose

precompile target: desktop_theme 

rake aborted!

NoMethodError: undefined method `resolve_baked_field' for nil:NilClass


Step :one: would be to be on latest, are you?

After that I would disable theme by theme to find which is the problem one.

Yes … this was bulk standard

./launcher rebuild app

on a staging site which as I understand it gets the latest version.

How do you disable themes on an instance that is not running?

Does it give you more than that? Typically, there’s a backtrace there.

Based on the solution another post with a similar issue.

I did the following

  1. Added DONT_PRECOMPILE_CSS: 1 to /var/discourse/containers/app.yml
  2. /var/discourse/launcher rebuild app which worked
  3. Selected a default theme in {{host}}/admin/customize/themes … no default theme was selected.
  4. Commented out DONT_PRECOMPILE_CSS: 1 in /var/discourse/containers/app.yml
  5. /var/discourse/launcher rebuild app again, which worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.