Unsecure error message

Hi everyone,
My first time installing, and I’m running into a roadblock. Here are the details:

  • My url is hosted at 1&1
  • I’m using mailgun, and it is “active”, and I’ve updated my DNS setting with mailgun requirements.
  • I’ve setup a 2GB $10 droplet at DigitalOcean.

Now, I open the console through Digital Ocean, login fine (root + password), and go through all of the discourse configuration steps without any errors UNTIL the end of the intial configuration. When I go to my IP address in Firefox, I get the user registration wizard, I fill it out, and when I submit it, I get an unsecure connection message. I check my email, and the discourse confirmation email is there. If I click the link, it also sends me to an unsecure connection message.

Any thoughts and/or guidance? Please excuse my ignorance – I’m a good student, and you time will be much appreciated.

I aslo have my A record pointing to my Digital Ocean IP address. That and the mailgun DNS settings are all that I have. Am I missing something?

Access by IP is completely unsupported.

Have you configured SSL? If so, how?

I uncommeted the three lines of let’s encrypt code and added my email at /var/discourse/containers/app.yml

Do.i need to do something else?

I can see now that it works on safari, albeit, not secure. How do I resolve? I thought using Let’s Encrypt took care of securing the site. What else do I need to do? Thank you in advance!

@Stephen, do I need to rebuild after I uncomment for Let’s Encrypt?

Yes, you need to uncomment let’s encrypt, web.ssl, the expose 443, and provide an email for the lets encrypt email field.

Thank you, @Stephen, but that’s not working. On my ipad/safari, I can access the site with an unsecure warning. But, on my computer firefox, this is what I get (www):

This is what I get (no www – notice https):

If I try just the IP address, I get a white screen:

Here’s screenshot from my console:
[I removed the screenshot that showed my email address]

Here’s DNS settings where my url is hosted:

Here’s a screenshot from DNS checker site:

What am I messing up on? Thank you, again, for helping me with this!!!

And you have rebuilt since editing the app.yml to include those fields?

I would recommend removing the screenshot with your email address.

Is this hosted on a DSL line?

I didn’t rebuild after uncommenting. I will do that. Yes, DSL.

You may well find your ISP disallows traffic to :443 then.

Ok. What would I do then?

The rebuild worked!! I’m live on all browsers now, but only without “www” – how do I get my site to work if a user types in the www? Do I add a A record www in my DNS settings?


Nearly all consumer-grade connections prohibit running servers. If your ISP detects it then at best you will get a nasty letter, at worst they might terminate your connection. I would consult their ToS to see what their enforcement policy is.

Okay. THank you for the education.

Thoughts on my last question? How to get the www.mysite.com to work – right now it only works without “www.”

Nevermind. The www A record worked. THANKS AGAIN!!!

1 Like