Update error, website unavailable, possibly plugin related?


#1

Dear all,
I have a problem… first of all, I am no expert, so please, bear with me.

I tried to upgrade discourse from the UI, then if I went to upgrade the plugins I got this:

<html><head></head><body>
<h2>You are running an old version of the Discourse image.</h2>
<p>
Upgrades via the web UI are disabled until you run the latest image.
</p>
<p>
To do so log in to your server using SSH and run:
</p>

<pre>
cd /var/discourse
git pull
./launcher rebuild app
</pre>
<p>
<a href='https://meta.discourse.org/t/how-do-i-update-my-docker-image-to-latest/23325'>More info on our support site</a>
</p>
</body>
</html>

The website was still working fine by then.

Then I went to a remote shell, and followed this guide: How do I manually update Discourse and Docker image to latest?

What happened was the following error.

now the website isn’t working anymore. just not reachable.
Any idea about what I should do? I am at a bit of a loss, and seem to find no relevant guide or thread, in here. I just really need to get this to work without losing any data or options…


(Bhanu Sharma) #2

Problem seems like related to babble Plugin!

maybe try this:

cd /var/discourse
nano containers/app.yml

remove the line

- git clone -b beta https://github.com/gdpelican/babble.git

and then Hit Ctrl + O to save the file, Ctrl + X to exit nano and then Run

git pull
./launcher rebuild app

This will disable the beta version of babble but the rest of the site may be back. then, Try revisiting babble’s repo and install the latest stable version!

To install Babble’s stable version,
add this line to where the old line was removed from:

- git clone https://github.com/gdpelican/babble.git

#3

Bhanu, thank you so much, it worked like a charm!
Have a great day and/or evening :slight_smile: