Error while updating discourse installation

Hello there, this Habib,

I have been trying to update my discourse installation through the link provided in the dashboard, but unfortunately, an error and now I cant go back to site as it says that


The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We’ll take a look at it.

No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site’s feedback category.

Please I need your support

Thank you

Can you share what plugins you are using?

Am not really sure but I guess category moderator,
Am still new and still learning about the system, but its a system where we moderate jobs, trainings, tenders among others,

So it was demanding upgrade then I decided to click on the upgrade button

This is the site

Hello and welcome @Habib :slight_smile:

Do you have access to the server so you can try an upgrade/rebuild from there?

You could also check your /logs page to see if there’s more information in there you could share -

1 Like

Let me try to access and see,
But the link for logs is not opening or displaying anything

I ssh in server and tried to upgrade but it says that no such file or directory
But when I ls after entering discourse, it shows launcher in green and not blue

I’m not sure of the significance of the green/blue, but to upgrade from your server you would normally:

cd /var/discourse
./launcher rebuild app

Could give us a little more detail about your setup? Is it a standard install? And do you have any third-party plugins installed?

try this:

cd /var/discourse
ls containers

You should have either app.yml or web_only.yml.

Given that you have app.yml, you’ll then do this:

./launcher rebuild app
1 Like

Yeah I can see that, but it now says that cannot connect to the docker demon - verify its running and you have access

Yeah the command worked, but it now says that cannot connect to the docker demon - verify its running and you have access