Update from 2.9.0 beta 3 to beta 4 failed - Site is down

Hi,

Went to update from 2.9.0 beta 3 to beta 4. From the web interface Has failed. Followed git pull, /launcher rebuild app doesn’t help.

Finishes with:

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake themes:update assets:precompile' failed with return #<Process::Status: pid 647 exit 134>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"assets_precompile", "cmd"=>["su discourse -c 'bundle exec rake themes:update assets:precompile'"]}
bootstrap failed with exit code 134
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
f5cd177671cf156b418115fd9956929e98c03223fbab30c91da284cee52510e3
==================== END REBUILD LOG ====================
Failed to rebuild app.

Discourse doctor hasn’t helped.

I can’t see anything error like higher in the log, some warnings around the Theme plugin Slick. But it gets truncated in powershell.

A bit unsure of where the log files for upgrading are. I did a ./launcher build app | tee ~\Rebuild.txt

But that has left me in some weird state, with a very short log file ~50 lines. The forums started, but still on beta 3. Very slow and can’t access any posts.

I did make a backup just before I updated.

How much memory and swap do you have?

 free -h
              total        used        free      shared  buff/cache   available
Mem:            14G        661M        5.3G        684K        8.4G         13G
Swap:            0B          0B          0B

Add 8g of swap, and watched the rebuild with top. Never touched swap. Tried to rebuild, still failed.

Checking up through the log (how/where is the output log?). There is a memory dump from a process crash. Still not sure where any logs are, but found the buffer limit in powershell and upped it. Log attached.

ErrorLog.txt (567.0 KB)

Looks like awesome-bbcodes is erroring? I’ll turn it off and try again.

Could we get in future versions, that if the rebuild errors, it gives the location of the rebuild log?

You can run ./discourse-doctor which generates a log of the rebuild and stores it in /tmp

An you’re correct, from the looks of it, looks like the awesome bbcode theme component plugin is erroring and causing rebuild to fail.

Try doing ./launcher start app and disable the component then rebuild again.

2 Likes

Removed it from the app.yml and rebuilt. Appears to be good now. Trying a rebuild with discourse-custom-bbcodes

Thanks.

1 Like

I didn’t realize it was a plugin. Good to know you figured it.

Yeah, the cooking process and tests require the back-end.

2 Likes