Update timing increasing?

Apologies if this is covered elsewhere, I searched and did not see a similar topic.

Are discourse updated taking exponentially longer recently than in the past?

I run a standalone instance in AWS Lightsail, and most updates felt like they took <5 minutes.

Now it seems like updates are taking 45+ minutes, and some of it appears to be duplicate work.

The gating update seems to be docker manager, and then when you update the remaining components, a 2x penalty seems to be incurred on rebuild.

I have a huge amount of respect for the developers in this community, and wish I had a suggestion for improvement beyond “something seems wrong/duplicate/out of sequence”.

Thanks for listening.

Builds have gone slow in the recent past due to some changes that have been discussed in the following topic


Guess I jinxed myself.

My site is now down. Won’t say unrecoverable yet, if there is a link on things to try that would be great.

I’ve tried doing a launcher app rebuild with no luck from the command line.

Nothing like unjinxing yourself with a follow up post.

While I cannot say at all why the updates failed last night, I was able to recover via app rebuild this morning.

Ain’t technology grand? :wink:

1 Like

Saga continues.

UI shows components “still upgrading” in the versions page of the admin perform updates here console.

I can grab the directions for the command line to do the updates.

Anyone have any insight on how to get proper status/ UI “unstuck”?

I’m running 2.9.0.beta4 as far as I can tell :grin: