Updated image on gravatar, not seeing it update on site

I updated the image for the email address I use on our private forum on gravatar about a week ago.

It looks correct when I check here:
https://en.gravatar.com/site/check/

But It’s not updated on our private site yet.

I tried switching my profile to use the letter avatar and back again, but that didn’t do the trick.

Do I need to restart the server or something?

Did you try hitting this button?

Yeah, I tried that. The image in that dialog did not change. I just tried clicking “Save Changes” anyway… haven’t seen it update yet.

Can we verify that gravatar refresh button here is still working in latest code @techapj? More than one report of this that I’ve seen…

Hi,

I also notice that profile image has not changed after updating my Gravatar.

The gravatar update code was broken and was fixed 4 days ago.

@mcwumbly can you repro this issue on latest Discourse version?.

6 Likes

Ah that looks like it’s probably it. I’ll last you know for sure after I do the next update. I was waiting for things to settle down a bit with some of the work currently going on (featured links, groups, ember), but I will update things soon.

UPDATE confirmed this is fixed in the latest version.

5 Likes

I’m seeing this behavior again both on my installation of Discourse and on this installation. I updated my Gravatar quite a while ago and have clicked the refresh button with no luck. I am running 1.8.0.beta8

EDIT Scratch that, it seems to be updating fine on this installation. I’ll have to poke at my own install.

Should I use this button at all? Can’t Discourse update it eventually (or just use gravatar directly)?

Discourse will create a local copy of the image, so you should use this button if you want the Avatar to update.

5 Likes

Let me say it from another viewpoint:

If a user sets to use gravatar, why on Earth would they not update their gravatar?

Why sould the user take action, and not that is the default to update silently?

1 Like

Just installed v2.5.0.beta2 and experience the same issue: after user creation it shows gravatar image, but can’t update it after image change on gravatar side. I see nothing in the /var/discourse/shared/standalone/log/rails/production.log pressing image reload in the user interface.

1 Like

Is there any update?

1 Like

Can we repro this @tshenry?

2 Likes

I can repro! The gravatar fails to update after I change it on https://en.gravatar.com/emails and select the refresh button on the Discourse user profile.

I also tried running rake avatars:refresh to see if that would do anything, but no luck.

1 Like

We should investigate this, can you assign Friday @eviltrout?

But wait: let’s give this the weekend to see if it is a cache propagation issue. Can you set a topic timer @tshenry to refresh on Monday?

2 Likes

Jeff, if you mean HTTP cache so the answer is NO. More than a week has already passed for my attempts with no success.

3 Likes

This is meant to correct the avatar right away looking at the code:

https://github.com/discourse/discourse/blob/ce00da3bcd29f1555dcfcfe241e968efbd249944/app/controllers/user_avatars_controller.rb#L7-L14

@kris.kotlarek can you repro this issue and fix?

Gravatar could very possibly be at fault here, caching something on their end for too long.

3 Likes

@kris fixed this by adding a random parameter to the URL.

4 Likes