Upgrade failed because Docker out of date


(Zajako) #1

Hello,

I was trying to use the admin panel update and it froze up.

This caused the main pages to stop working, only admin pages worked.

I went to /var/docker and did “git pull”

it fixed things so the website works again however I can’t rebuild the app as this happens:
boards:/var/docker# ./launcher rebuild app
ERROR: Docker version 0.11.1 not supported, please upgrade to at least 1.2.0, or recommended 1.2.0

I can’t figure out how to update docker by itself and the admin panel is pretty broken now, not sure if the boards themselves are functioning fully either.

This is what my admin panel looks like: Image 2015-07-05 at 2.41.44 PM.png

Honestly, I’m not sure my /var/docker folder is docker at all, I think its just discourse. I installed it back when discourse was in the 0.x versions using the tutorial posted at the time.

So I’m not sure what to do to restore things to full functionality, anyone able to help?

Thanks


#2

If you’re on DigitalOcean : you can upgrade some programs on your droplet by typing these commands :

sudo apt-get update

Press enter, after few seconds, type :

sudo apt-get upgrade

You should have a Y/n message, type Y

Then you’ll have to reboot your server :

shutdown -h now

And then in DigitalOcean, Power On your server, and Docker, and others programs should be updated.

Maybe you’ll have to rebuild your app, but I think it’ll fix your problem.


(Jeff Atwood) #3

You need to update Docker to a newer version. If you search here there are instructions on how to do that.


(Anja Schulz) #4

Sometimes security updates can’t be installed with

apt-get upgrade

then you can use

apt-get dist-upgrade

btw: reboot works easylier with

shutdown -r now


#5

Thanks good to know !


(Zajako) #6

Thanks guys, running the upgrades on the os and rebooting worked.

Everything seems to be back to full working order.


(Sam Saffron) #7